Bug 66053 - Cyrus-SASL seems to have recursion issues.
Cyrus-SASL seems to have recursion issues.
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: cyrus-sasl (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-04 20:06 EDT by zweers
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:12:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zweers 2002-06-04 20:06:11 EDT
I submitted a bug for Cyrus-imap and/or Cyrus-sasl with RH70 I believe (I can't
seem to find the report in Bugzilla, and I am currently unable to access my email)

I use cyrus-imap and openldap for authentication.  There seems to be a problem
with cyrus-sasl and recursion.  Basically, cyrus-imap and openldap use
cyrus-sasl to authenticate and be authenticated.  Essentially the second calling
of cyrus-sasl kills the first call when it completes.

I found this site which discusses the problem and gives a patch.  I had been
running cyrus-sasl for a while with this patch applied, but with the new version
of cyrus-sasl, I need to rebuild the RPM and reapply the patch.

http://www.netsys.com/pamldap/2001/08/msg00070.html

If this bug was the reason that cyrus-imap was dropped from RedHat, please
consider bring it back.
Comment 1 Bill Nottingham 2006-08-07 13:10:29 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 2 Bill Nottingham 2006-10-18 10:12:02 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.