Bug 66056 - Can't turn on DMA on Intel SCB2 motherboard
Can't turn on DMA on Intel SCB2 motherboard
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-04 20:45 EDT by Samuel Flory
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 14:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samuel Flory 2002-06-04 20:45:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
System fails to turn on DMA via "hdparm -d 1 /dev/hda".  This works and burns in
just fine under cerberus (in r/w data test mode) under RH 7.2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install 7.3
2.hdparm -d 1 /dev/hda
	

Additional info:

  This issue is the result of the ide code imported from the ac kernel tree.  It
works just fine under 2.4.18 from kernel.org.
Comment 1 Seth Bardash 2002-06-11 23:13:47 EDT
Have same problem with Gigabyte GA-7VKML motherboard, XP2100, 512 MB DDR 
memory, Maxtor 20GB ATA-133 disk (hda) and CDROM (hdc). This board uses the VIA 
KM266 / VT 8233A chipset.

Any help or a patch would be apppreciated.
Comment 2 Need Real Name 2002-10-21 16:01:04 EDT
Same problem. Arise for me since a kernel update. Had to switch back to the
previous update. With the new kernel:
- hdparm refuses to change DMA flag
- /etc/sysconfig/harddisk{s,hdc,hdd} conf files ignored (same reason I believe)

My setup:
- Redhat 7.3
- Asus A7V motherboard with VIA chipset, T-bird processor
- DMA flag change OK with kernel-2.4.18-10.athlon.rpm
- DMA flag change denied with kernel-2.4.18-17.7.x.athlon.rpm (hdparm fails)

I'm Wondering if some security patch made the kernel too fussy when changing DMA
settings.

Christophe
Comment 3 Arjan van de Ven 2003-06-07 14:50:09 EDT
the current erratum should default to DMA on for this

Note You need to log in before you can comment on or make changes to this bug.