Bug 660629 - POSTIN scriptlet failure in 2:qemu-system-x86-0.13.0-1.fc14.x86_64
POSTIN scriptlet failure in 2:qemu-system-x86-0.13.0-1.fc14.x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
17
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-07 06:39 EST by Milan Kerslager
Modified: 2013-01-09 06:43 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 18:59:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2010-12-07 06:39:59 EST
I've got this when trying to do: yum install Virtualization

Non-fatal POSTIN scriptlet failure in rpm package 2:qemu-system-x86-0.13.0-1.fc14.x86_64
warning: %post(qemu-system-x86-2:0.13.0-1.fc14.x86_64) scriptlet failed, exit status 1
Comment 1 Justin M. Forbes 2010-12-09 12:20:41 EST
Can you tell me a bit more about your system? Do kvm modules load? 'lsmod | grep kvm'
The post for qemu simply does a sh %{_sysconfdir}/sysconfig/modules/kvm.modules which loads the kvm-intel module if the vmx CPU flag is present, and loads the kvm-amd module if the svm CPU flag is present.  If the modules are not loaded, can you load them yourself? 'modprobe -b <module>' where the module is the correct one for your hardware.
Comment 2 Milan Kerslager 2010-12-10 02:47:08 EST
The bug arised on fresh F14 system where I did:

yum groupinstall Virtualization

I have kvm loaded. Maybe there should be some package installed before qemu-system. The order of installed packages was (as in /var/log/yum.log):

Dec 07 12:33:13 Installed: augeas-libs-0.7.4-1.fc14.x86_64
Dec 07 12:33:15 Installed: netcf-libs-0.1.7-1.fc14.x86_64
Dec 07 12:33:16 Installed: yajl-1.0.7-3.fc13.x86_64
Dec 07 12:33:17 Installed: celt051-0.5.1.3-2.fc14.x86_64
Dec 07 12:33:18 Installed: spice-server-0.6.3-4.fc14.x86_64
Dec 07 12:33:19 Installed: libibverbs-1.1.3-4.fc13.x86_64
Dec 07 12:33:20 Installed: libmlx4-1.0.1-6.fc14.x86_64
Dec 07 12:33:22 Installed: glusterfs-common-2.0.9-2.fc14.x86_64
Dec 07 12:33:23 Installed: lzop-1.02-0.9.rc1.fc14.x86_64
Dec 07 12:33:24 Installed: bridge-utils-1.2-9.fc13.x86_64
Dec 07 12:33:27 Installed: 2:qemu-common-0.13.0-1.fc14.x86_64
Dec 07 12:33:29 Installed: iscsi-initiator-utils-6.2.0.872-8.fc14.x86_64
Dec 07 12:33:29 Installed: 2:qemu-img-0.13.0-1.fc14.x86_64
Dec 07 12:33:31 Installed: ebtables-2.0.9-5.fc13.x86_64
Dec 07 12:33:31 Installed: gtk-vnc-python-0.4.2-3.fc14.x86_64
Dec 07 12:33:32 Installed: glusterfs-client-2.0.9-2.fc14.x86_64
Dec 07 12:33:33 Installed: xen-licenses-4.0.1-6.fc14.x86_64
Dec 07 12:33:34 Installed: xen-libs-4.0.1-6.fc14.x86_64
Dec 07 12:33:38 Installed: libvirt-client-0.8.3-2.fc14.x86_64
Dec 07 12:33:39 Installed: libvirt-python-0.8.3-2.fc14.x86_64
Dec 07 12:33:41 Installed: python-virtinst-0.500.4-1.fc14.noarch
Dec 07 12:33:41 Installed: seabios-bin-0.6.0-1.fc14.noarch
Dec 07 12:33:42 Installed: vgabios-0.6c-2.fc14.noarch
Dec 07 12:33:42 Installed: gpxe-roms-qemu-1.0.1-1.fc14.noarch
Dec 07 12:33:44 Installed: 2:qemu-system-x86-0.13.0-1.fc14.x86_64
Dec 07 12:33:46 Installed: libvirt-0.8.3-2.fc14.x86_64
Dec 07 12:33:46 Installed: virt-viewer-0.2.1-1.fc13.x86_64
Dec 07 12:33:47 Installed: 2:qemu-kvm-0.13.0-1.fc14.x86_64
Dec 07 12:33:52 Installed: virt-manager-0.8.5-1.fc14.noarch
Comment 3 Justin M. Forbes 2010-12-14 10:19:55 EST
This is curious, as I said, the qemu-system-x86 post only uses sh and modprobe, both of which have to be installed before you can even get to a yum prompt.  I am guessing there was some issue probing the module on your system at install time for some reason.  Going to close this, as I cannot reproduce or see any dependency issue which would cause this.  If you run into it again please feel free to reopen.
Comment 4 Orion Poplawski 2012-03-22 17:39:13 EDT
On systems without kvm support, "sh /etc/sysconfig/modules/kvm.modules" will return 1.  You need:

sh /etc/sysconfig/modules/kvm.modules || :

in the %post script.
Comment 5 Cole Robinson 2012-07-29 18:20:15 EDT
Thanks for tracking this down, Orion! I'll be pushing a fix to all branches shortly.
Comment 6 Fedora Update System 2012-07-30 07:25:08 EDT
qemu-1.0.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qemu-1.0.1-1.fc17
Comment 7 Fedora Update System 2012-07-30 18:28:44 EDT
Package qemu-1.0.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.0.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11302/qemu-1.0.1-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-08-01 14:47:06 EDT
qemu-0.15.1-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-11305/qemu-0.15.1-7.fc16
Comment 9 Fedora Update System 2012-08-01 14:50:43 EDT
qemu-0.15.1-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-11305/qemu-0.15.1-7.fc16
Comment 10 Fedora Update System 2012-08-09 18:59:34 EDT
qemu-0.15.1-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-08-09 19:01:44 EDT
qemu-1.0.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.