Bug 660652 - broken dependencies in EPEL6beta
Summary: broken dependencies in EPEL6beta
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: perl-DateTime
Version: el6
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Mark Chappell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-07 13:54 UTC by Tomas Lestach
Modified: 2014-01-13 10:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-13 10:07:13 UTC


Attachments (Terms of Use)

Description Tomas Lestach 2010-12-07 13:54:58 UTC
Description of problem:
Missing dependencies in EPEL6beta

Version-Release number of selected component (if applicable):
1:perl-DateTime-0.5300-4.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. rpm -Uvh http://download.fedora.redhat.com/pub/epel/beta/6/x86_64/epel-release-6-5.noarch.rpm
2. yum install perl-DateTime.x86_64
  
Actual results:
# yum install perl-DateTime.x86_64
Loaded plugins: rhnplugin
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package perl-DateTime.x86_64 1:0.5300-4.el6 set to be updated
--> Processing Dependency: perl(Class::Singleton) >= 1.03 for package: 1:perl-DateTime-0.5300-4.el6.x86_64
--> Processing Dependency: perl(Params::Validate) >= 0.91 for package: 1:perl-DateTime-0.5300-4.el6.x86_64
--> Processing Dependency: perl(List::MoreUtils) for package: 1:perl-DateTime-0.5300-4.el6.x86_64
--> Processing Dependency: perl(Class::Singleton) for package: 1:perl-DateTime-0.5300-4.el6.x86_64
--> Processing Dependency: perl(Params::Validate) for package: 1:perl-DateTime-0.5300-4.el6.x86_64
--> Finished Dependency Resolution
Error: Package: 1:perl-DateTime-0.5300-4.el6.x86_64 (epel)
           Requires: perl(List::MoreUtils)
Error: Package: 1:perl-DateTime-0.5300-4.el6.x86_64 (epel)
           Requires: perl(Class::Singleton)
Error: Package: 1:perl-DateTime-0.5300-4.el6.x86_64 (epel)
           Requires: perl(Class::Singleton) >= 1.03
Error: Package: 1:perl-DateTime-0.5300-4.el6.x86_64 (epel)
           Requires: perl(Params::Validate) >= 0.91
Error: Package: 1:perl-DateTime-0.5300-4.el6.x86_64 (epel)
           Requires: perl(Params::Validate)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
all dependencies shall be either in RHEL6 or in EPEL6beta

Comment 1 Mark Chappell 2014-01-13 10:07:13 UTC
Missing dependencies are in Optional Repo.


Note You need to log in before you can comment on or make changes to this bug.