Bug 661143 (votca-tools) - Review Request: votca-tools - VOTCA tools library
Summary: Review Request: votca-tools - VOTCA tools library
Keywords:
Status: CLOSED ERRATA
Alias: votca-tools
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 660061 (view as bug list)
Depends On:
Blocks: votca-csg
TreeView+ depends on / blocked
 
Reported: 2010-12-07 21:43 UTC by Susi Lehtola
Modified: 2010-12-25 00:27 UTC (History)
3 users (show)

Fixed In Version: votca-csg-1.0.1-2.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-25 00:27:10 UTC
dominik: fedora-review+
tibbs: fedora-cvs+


Attachments (Terms of Use)

Description Susi Lehtola 2010-12-07 21:43:09 UTC
Spec URL:
http://theory.physics.helsinki.fi/~jzlehtol/rpms/votca-tools.spec

SRPM URL:
http://theory.physics.helsinki.fi/~jzlehtol/rpms/votca-tools-1.0.1-1.fc14.src.rpm

Upstream URL:
http://www.votca.org

Description:
Versatile Object-oriented Toolkit for Coarse-graining Applications (VOTCA) is
a package intended to reduce the amount of routine work when doing systematic
coarse-graining of various systems. The core is written in C++. 

rpmlint output:

votca-tools.src: W: spelling-error %description -l en_US graining -> gaining, raining, training
votca-tools.src: W: invalid-url Source0: http://votca.googlecode.com/files/votca-tools-1.0.1.tar.gz HTTP Error 404: Not Found
votca-tools.x86_64: W: spelling-error %description -l en_US graining -> gaining, raining, training
votca-tools.x86_64: W: shared-lib-calls-exit /usr/lib64/libvotca_tools.so.0.0.0 exit@GLIBC_2.2.5
votca-tools-devel.x86_64: W: spelling-error %description -l en_US graining -> gaining, raining, training
votca-tools-devel.x86_64: W: no-documentation
4 packages and 0 specfiles checked; 0 errors, 6 warnings.


These are all OK.

Comment 1 Susi Lehtola 2010-12-07 22:22:39 UTC
*** Bug 660061 has been marked as a duplicate of this bug. ***

Comment 2 Christoph Junghans 2010-12-08 12:59:40 UTC
Notes from my side:
- "coarse-graining" is spell correctly.
- I have removed the exit call in libtools, this will be fixed in the next release
- there is doxygen documentation through 'make html'

Comment 3 Dominik 'Rathann' Mierzejewski 2010-12-13 21:22:55 UTC
Taking the review.

Comment 4 Dominik 'Rathann' Mierzejewski 2010-12-13 23:51:48 UTC
Source matches upstream:
$ md5sum votca-tools-1.0.1.tar.gz*
8401cc8f762543a89cb015ef153ca172  votca-tools-1.0.1.tar.gz
8401cc8f762543a89cb015ef153ca172  votca-tools-1.0.1.tar.gz.1

Notes:

1. If you intend to build for EPEL5, you need to add Requires: pkgconfig to the -devel subpackage.

2. "install -p" should be used instead of plain install to preserve timestamps, please override that with INSTALL="install -p"

Otherwise the package is fine. Please fix number 2 and it will be approved.

(In reply to comment #2)
> - there is doxygen documentation through 'make html'

Doesn't work:
$ make html
...
Making html in doc
make[2]: Entering directory `/home/rathann/build/BUILD/votca-tools-1.0.1/share/doc'
make[2]: *** No rule to make target `Doxyfile', needed by `html'.  Stop.

Comment 6 Christoph Junghans 2010-12-14 08:59:50 UTC
(In reply to comment #4)
> 2. "install -p" should be used instead of plain install to preserve timestamps,
> please override that with INSTALL="install -p"
Is this a problem in our build system or in autotools?

> (In reply to comment #2)
> > - there is doxygen documentation through 'make html'
> Doesn't work:
> make[2]: *** No rule to make target `Doxyfile', needed by `html'.  Stop.
I forgot to add 'Doxyfile' to EXTA_DIST (fixed in the next release). 
In case you still want it, it can be found here:
http://tools.votca.googlecode.com/hg/share/doc/Doxyfile
But I think it is not necessary due to the fact that one can browse the documentation at http://doc.votca.org

Comment 7 Dominik 'Rathann' Mierzejewski 2010-12-14 10:37:49 UTC
Excellent.

This package is APPROVED.

Comment 8 Dominik 'Rathann' Mierzejewski 2010-12-14 10:39:52 UTC
(In reply to comment #6)
> (In reply to comment #4)
> > 2. "install -p" should be used instead of plain install to preserve timestamps,
> > please override that with INSTALL="install -p"
> Is this a problem in our build system or in autotools?

autotools don't use -p by default.

> I forgot to add 'Doxyfile' to EXTA_DIST (fixed in the next release). 
> In case you still want it, it can be found here:
> http://tools.votca.googlecode.com/hg/share/doc/Doxyfile
> But I think it is not necessary due to the fact that one can browse the
> documentation at http://doc.votca.org

Indeed.

Comment 9 Susi Lehtola 2010-12-14 16:42:44 UTC
Thanks a lot for the review!

New Package SCM Request
=======================
Package Name: votca-tools
Short Description: VOTCA tools library
Owners: jussilehtola
Branches: F-13 F-14
InitialCC:

Comment 10 Jason Tibbitts 2010-12-14 16:50:44 UTC
Git done (by process-git-requests).

Comment 11 Fedora Update System 2010-12-15 10:58:12 UTC
votca-tools-1.0.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/votca-tools-1.0.1-2.fc14

Comment 12 Fedora Update System 2010-12-15 10:58:20 UTC
votca-tools-1.0.1-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/votca-tools-1.0.1-2.fc13

Comment 13 Fedora Update System 2010-12-15 11:00:14 UTC
votca-csg-1.0.1-2.fc13,votca-tools-1.0.1-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/votca-csg-1.0.1-2.fc13,votca-tools-1.0.1-2.fc13

Comment 14 Fedora Update System 2010-12-15 11:01:08 UTC
votca-csg-1.0.1-2.fc14,votca-tools-1.0.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/votca-csg-1.0.1-2.fc14,votca-tools-1.0.1-2.fc14

Comment 15 Fedora Update System 2010-12-17 08:20:11 UTC
votca-csg-1.0.1-2.fc14, votca-tools-1.0.1-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update votca-csg votca-tools'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/votca-csg-1.0.1-2.fc14,votca-tools-1.0.1-2.fc14

Comment 16 Fedora Update System 2010-12-25 00:27:01 UTC
votca-csg-1.0.1-2.fc14, votca-tools-1.0.1-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2010-12-25 00:27:42 UTC
votca-csg-1.0.1-2.fc13, votca-tools-1.0.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.