Bug 661206 - connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine 'anthy'.
connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Fai...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-08 01:40 EST by Jens Petersen
Modified: 2010-12-21 19:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-21 19:50:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2010-12-08 01:40:44 EST
Description of problem:
When I activate anthy in rawhide I get an abrt backtrace.

Unfortunately ABRT seems to mistake this as a duplicate
of bug 522047, which looks wrong to me.

Version-Release number of selected component (if applicable):
ibus-1.3.99.20101118-2.fc15.x86_64
ibus-anthy-1.2.5-1.fc15.x86_64

How reproducible:
every time after desktop startup

Steps to Reproduce:
1. start default gnome desktop
2. select an IC
3. activate anthy by mouse (same using hotkey I expect)
  
Actual results:
connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine 'anthy'.

Traceback (most recent call last):
  File "/usr/share/ibus/ui/gtk/panel.py", line 501, in __im_menu_item_activate_cb
    self.__focus_ic.set_engine(engine)
  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 239, in set_engine
    return self.__context.SetEngine(engine.name)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.Failed: Can not find engine 'anthy'.

Local variables in innermost frame:
byte_arrays: False
self: <dbus.connection.Connection object at 0x1c7a1d0>
args: (dbus.String(u'anthy'),)
utf8_strings: False
bus_name: 'org.freedesktop.IBus'
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_2')
timeout: -1.0
signature: u's'
dbus_interface: 'org.freedesktop.IBus.InputContext'
message: <dbus.lowlevel.MethodCallMessage object at 0x1e23708>
method: 'SetEngine'

Expected results:
no backtrace
Comment 1 Jens Petersen 2010-12-08 01:45:27 EST
(In reply to comment #0)
> 3: (same using hotkey I expect)

Not true: only backtrace when activating with mouse via applet.
Comment 2 fujiwara 2010-12-08 04:25:00 EST
Hmm.., I cannot reproduce your problem.

>   File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 239, in
set_engine
>     return self.__context.SetEngine(engine.name)

It means the python code calls the remote method in ibus-daemon but I'm not sure why anthy is not found by ibus-daemon.
Comment 3 fujiwara 2010-12-09 02:02:37 EST
The latest is ibus-1.3.99.20101202-1.fc15.
Probably I need to know if the problem can be reproduced with the latest ibus.

I use gtk3-2.91.4-2.fc15.x86_64, gtk2-2.23.2-1.fc15.x86_64 and gnome-terminal-2.33.2-1.fc15.x86_64 .
Comment 4 Jens Petersen 2010-12-21 04:50:20 EST
Not 100% sure but I think it is probably gone now.
Comment 5 fujiwara 2010-12-21 19:50:17 EST
Thanks for the test.

Note You need to log in before you can comment on or make changes to this bug.