Bug 661219 - en_DK locale not supported by xterm/Xlib
en_DK locale not supported by xterm/Xlib
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libX11 (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: i18n, Triaged
Depends On:
Blocks: 842499
  Show dependency treegraph
 
Reported: 2010-12-08 03:05 EST by Ulf Tigerstedt
Modified: 2014-11-18 02:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 02:44:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulf Tigerstedt 2010-12-08 03:05:15 EST
Description of problem:

When using the locale "en_DK.UTF8" xterm reverts back to 
non-UTF8 mode and gives the error:
Warning: locale not supported by Xlib, locale set to C



Version-Release number of selected component (if applicable):
libX11-1.3-2.el6.x86_64
xterm-253-1.el6.x86_64

How reproducible:
Install machine with en_DK.UTF8 locale, try to use UTF-chars
in an xterm.



Steps to Reproduce:
1.
2.
3.
  
Actual results:
.. a terminal that supports ISO8859-1/C but with LANG=en_DK.UTF8

Expected results:
.. a terminal that supports UTF-8 and with LANG=en_DK.UTF8


Additional info:
Comment 2 A S Alam 2010-12-08 04:25:37 EST
Triaged
Comment 3 RHEL Product and Program Management 2011-01-07 10:41:00 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 Jens Petersen 2014-11-18 02:06:38 EST
I suspect en_DK.UTF8 might not be a valid X locale.

Does en_DK.UTF-8 or en_DK.utf8 work?
Comment 6 Ulf Tigerstedt 2014-11-18 02:12:31 EST
(It's rhel6.6 now)

[tigerste@supernaakka Downloads]$ locale
LANG=en_IE.utf8
LC_CTYPE="en_IE.utf8"
LC_NUMERIC="en_IE.utf8"
LC_TIME="en_IE.utf8"
LC_COLLATE="en_IE.utf8"
LC_MONETARY="en_IE.utf8"
LC_MESSAGES="en_IE.utf8"
LC_PAPER="en_IE.utf8"
LC_NAME="en_IE.utf8"
LC_ADDRESS="en_IE.utf8"
LC_TELEPHONE="en_IE.utf8"
LC_MEASUREMENT="en_IE.utf8"
LC_IDENTIFICATION="en_IE.utf8"
LC_ALL=
[tigerste@supernaakka Downloads]$ export LANG="en_DK.UTF-8"
[tigerste@supernaakka Downloads]$ xterm 
^C[tigerste@supernaakka Downloads]$ export LANG="en_DK.UTF8"
[tigerste@supernaakka Downloads]$ xterm 
Warning: locale not supported by Xlib, locale set to C



So yes, it works.
Now I just wonder what my original usecase was?
Ticket can be closed.
Comment 7 Jens Petersen 2014-11-18 02:44:31 EST
Thank you!

Sorry for not spotting this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.