Bug 66144 - up2date --config crashes if proxy user is numeric
up2date --config crashes if proxy user is numeric
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-05 08:37 EDT by Didier Arenzana
Modified: 2015-01-07 18:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-14 09:57:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Didier Arenzana 2002-06-05 08:37:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
I use a proxy to access the internet. This proxy needs user authentication, and
my username on this proxy consists of only numeric characters [0-9].
I used up2date --config to enter this information, and it worked.
Now chen I try to launch up2dtae --config, it stops with the following lines of
text:
 up2date --configure
Traceback (innermost last):
  File "/usr/sbin/up2date", line 1137, in ?
    main()
  File "/usr/sbin/up2date", line 339, in main
    configdlg.main()
  File "/usr/share/rhn/up2date_client/configdlg.py", line 311, in main
    gui = Gui()
  File "/usr/share/rhn/up2date_client/configdlg.py", line 62, in __init__
    self.setInitialValues()
  File "/usr/share/rhn/up2date_client/configdlg.py", line 74, in setInitialValues
    self.xml.get_widget("proxyUserEntry").set_text(self.cfg.readEntry("proxyUser"))
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2145, in set_text
    _gtk.gtk_entry_set_text(self._o, text)
TypeError: gtk_entry_set_text, argument 2: expected string, int found

The 'expected string, int found' makes me think the problem is with my   pproxy
user id that contains only numbers.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run up2date --config
2.Enter a numeric userid for the proxy authentication
3.Save the config
4.run up2date --config again
	

Actual Results:  up2date window does not open, and fails with the following error:
 up2date --configure
Traceback (innermost last):
  File "/usr/sbin/up2date", line 1137, in ?
    main()
  File "/usr/sbin/up2date", line 339, in main
    configdlg.main()
  File "/usr/share/rhn/up2date_client/configdlg.py", line 311, in main
    gui = Gui()
  File "/usr/share/rhn/up2date_client/configdlg.py", line 62, in __init__
    self.setInitialValues()
  File "/usr/share/rhn/up2date_client/configdlg.py", line 74, in setInitialValues
    self.xml.get_widget("proxyUserEntry").set_text(self.cfg.readEntry("proxyUser"))
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2145, in set_text
    _gtk.gtk_entry_set_text(self._o, text)
TypeError: gtk_entry_set_text, argument 2: expected string, int found


Expected Results:  the window should open :o)

Additional info:

One workaround I found was to manualy edit the config file in /etc/rhn/up2date.
Comment 1 Adrian Likins 2002-06-13 16:25:21 EDT
Hmmm, indeed. Looks like I need to stringify the proxy username
(and probabaly passwd).

Fixed in cvs, should be fixed in next release 2.9.x
Comment 2 Jay Turner 2003-02-14 09:57:36 EST
Fix confirmed with up2date-3.1.15-7.

Note You need to log in before you can comment on or make changes to this bug.