Bug 661459 - SELinux is preventing /usr/sbin/arpon "ioctl" access on packet_socket.
Summary: SELinux is preventing /usr/sbin/arpon "ioctl" access on packet_socket.
Keywords:
Status: CLOSED DUPLICATE of bug 661409
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:4e5b98dcdbf...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-08 19:35 UTC by maurizio
Modified: 2010-12-08 20:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-08 20:35:38 UTC
Type: ---


Attachments (Terms of Use)

Description maurizio 2010-12-08 19:35:23 UTC
Summary:

SELinux is preventing /usr/sbin/arpon "ioctl" access on packet_socket.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by arpon. It is not expected that this access is
required by arpon and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                mauricio:user_r:user_t:s0-s0:c0.c1023
Target Context                mauricio:user_r:user_t:s0-s0:c0.c1023
Target Objects                packet_socket [ packet_socket ]
Source                        snort
Source Path                   /usr/sbin/snort-plain
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ArpON-1.90-7.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-69.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.34.7-61.fc13.i686
                              #1 SMP Tue Oct 19 04:42:47 UTC 2010 i686 i686
Alert Count                   2
First Seen                    Wed 08 Dec 2010 09:48:43 AM MST
Last Seen                     Wed 08 Dec 2010 09:58:24 AM MST
Local ID                      d0bea731-15f8-4815-ae36-722e917d4d5d
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1291827504.774:126): avc:  denied  { ioctl } for  pid=2695 comm="arpon" path="socket:[168466]" dev=sockfs ino=168466 scontext=mauricio:user_r:user_t:s0-s0:c0.c1023 tcontext=mauricio:user_r:user_t:s0-s0:c0.c1023 tclass=packet_socket

node=(removed) type=SYSCALL msg=audit(1291827504.774:126): arch=40000003 syscall=54 success=yes exit=0 a0=3 a1=8933 a2=bff792cc a3=bff792cc items=0 ppid=2694 pid=2695 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts2 ses=1 comm="arpon" exe="/usr/sbin/arpon" subj=mauricio:user_r:user_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,snort,user_t,user_t,packet_socket,ioctl
audit2allow suggests:

#============= user_t ==============
allow user_t self:packet_socket ioctl;

Comment 1 Daniel Walsh 2010-12-08 20:35:38 UTC

*** This bug has been marked as a duplicate of bug 661409 ***


Note You need to log in before you can comment on or make changes to this bug.