This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 66154 - gnome terminal has font problems
gnome terminal has font problems
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-05 10:54 EDT by Joshua Jensen
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-05 10:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2002-06-05 10:54:39 EDT
Description of Problem:

Not sure where the problem is, filing against the application.  Please feel free
to put this bug report where it should go... I am not clear on where it should
be.  When changing the font in gnome-terminal to Courier (adobe) bold 16 point,
gnome-terminal does not change the font, but spits this error message at me instead:

The font "-adobe-courier-bold-r-normal-*-*-160-*-*-m-*-iso8859-9" does not
support all the required character sets for the current locale "en_US.iso885915"
  (Missing character set "ISO8859-15")
  (Missing character set "ISO8859-15")



Version-Release number of selected component (if applicable):

Stock RHL 7.3.

[joshua@server1 joshua]$ rpm -qf `which gnome-terminal`
gnome-core-1.4.0.4-54

[joshua@server1 joshua]$ rpm -qa | grep ISO
XFree86-ISO8859-15-75dpi-fonts-4.2.0-8
XFree86-ISO8859-2-100dpi-fonts-4.2.0-8
fonts-ISO8859-7-100dpi-1.0-2
fonts-ISO8859-7-75dpi-1.0-2
XFree86-ISO8859-15-100dpi-fonts-4.2.0-8
fonts-ISO8859-7-Type1-1.0-2
XFree86-ISO8859-2-75dpi-fonts-4.2.0-8
fonts-ISO8859-7-1.0-2

[joshua@server1 joshua]$ more /etc/sysconfig/i18n 
LANG="en_US.iso885915"
SUPPORTED="en_US.iso885915:en_US:en"
SYSFONT="lat0-sun16"
SYSFONTACM="iso15"


Additional Information:
	
I've seen this problem and a very similar error with gnucash as well.
Comment 1 Havoc Pennington 2002-06-05 11:26:32 EDT
You need to make the font encoding and your locale encoding match by changing
one of them, or uncheck the "enable multibyte support" button in gnome-terminal
preferences to allow them to mismatch. Just how traditional X fonts work.

There should be a better error message but the next release avoids the whole
issue with a new font subsystem, so keeping the bug open for that isn't really
worthwhile.

Note You need to log in before you can comment on or make changes to this bug.