This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 66155 - Building ncpfs-2.2.0.18-6.src.rpm doesn't produce same manifest as installed ncpfs RPM
Building ncpfs-2.2.0.18-6.src.rpm doesn't produce same manifest as installed ...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ncpfs (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-05 11:18 EDT by Glen A. Foster
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-05 11:21:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen A. Foster 2002-06-05 11:18:27 EDT
Description of Problem: SSIA.  If you build binary RPMs from the Source rpm of
ncpfs, the resulting binary RPMs don't have the same filenames as the version
placed on the system at install time.

THIS IS LOW PRIORITY but a defect nonetheless (IMO).

Version-Release number of selected component (if applicable):
# rpm -ql ncpfs
ncpfs-2.2.0.18-6
# ls ncpfs-2.2.0.18-6.src.rpm
-rw-r--r--    1 root     root       617846 Sep  7  2001 ncpfs-2.2.0.18-6.src.rpm
# md5sum ncpfs-2.2.0.18-6.src.rpm
e774fa64d0f6a662e6615ef650032c4a  ncpfs-2.2.0.18-6.src.rpm
# rpm -q ncpfs-2.2.0.18-6.src.rpm
ncpfs-2.2.0.18-6.src.rpm: md5 gpg OK

How Reproducible: 100% (always)

Steps to Reproduce:
0. Perform an everything install of 7.3 and reboot
1. rpm -ql ncpfs > /tmp/INSTALLED
2. rpm -Uvh {7.3distrodir}/SRPMS/SRPMS/ncpfs-2.2.0.18-6.src.rpm
3. rpm -ba /usr/src/redhat/SPECS/ncpfs.spec
4. rpm -qlp /usr/src/redhat/RPMS/i386/ncpfs-2.2.0.18-6.i386.rpm > /tmp/BUILT
5. diff /tmp/INSTALLED /tmp/BUILT

Voila.  The built version adds files in /usr/include.  Since this is a superset
of what's included in the shipped installable binary RPMs, it's not critical...
unless, of course, the shipped installable binary RPM should have had the same
include-files in it, too.
Comment 1 Glen A. Foster 2002-06-05 11:21:51 EDT
Oops, I left out the details.  I also see that a file in /usr/lib is in tbe
built version (compared to the version shipped with the default release):

[<] Installed : Built [>]
37a38,52
> /usr/include/ncp/ext/socket.h
> /usr/include/ncp/ext/stdint.h
> /usr/include/ncp/kernel/fs.h
> /usr/include/ncp/kernel/if.h
> /usr/include/ncp/kernel/ncp_fs.h
> /usr/include/ncp/kernel/ncp.h
> /usr/include/ncp/kernel/route.h
> /usr/include/ncp/kernel/types.h
> /usr/include/ncp/ncp.h
> /usr/include/ncp/ncplib.h
> /usr/include/ncp/ndslib.h
> /usr/include/ncp/nwcalls.h
> /usr/include/ncp/nwnet.h
> /usr/include/ncp/obsolete/o_ndslib.h
> /usr/lib/libncp.so
Comment 2 Florian La Roche 2002-06-17 06:42:48 EDT
release 9 or higher should have this fixed.

Thanks,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.