Bug 66163 - multiple items inside a listitem
Summary: multiple items inside a listitem
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: docbook-style-dsssl (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 66167 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-05 16:54 UTC by Tammy Fox
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-28 09:39:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case (476 bytes, text/plain)
2002-06-20 15:24 UTC, Tim Waugh
no flags Details
Custom stylesheet layer that seems to work around it. (826 bytes, text/plain)
2002-06-20 16:03 UTC, Tim Waugh
no flags Details
snippet to fix the extra space after a screen in a listitem (1.30 KB, text/plain)
2002-07-03 05:48 UTC, Tammy Fox
no flags Details
fix spacing after admon in listitem (2.84 KB, patch)
2002-07-13 23:38 UTC, Tammy Fox
no flags Details | Diff

Description Tammy Fox 2002-06-05 16:54:55 UTC
If there are multiple items inside a listitem, too much space is added
between the listitem and the next listitem. The items can be any 2+ of
the tags para, screen, itemizedlist, orderedlist, etc.

Comment 1 Tim Waugh 2002-06-20 15:24:36 UTC
Created attachment 61884 [details]
Test case

Comment 2 Tim Waugh 2002-06-20 16:03:08 UTC
Created attachment 61904 [details]
Custom stylesheet layer that seems to work around it.

Comment 4 Tammy Fox 2002-06-20 16:20:48 UTC
*** Bug 66167 has been marked as a duplicate of this bug. ***

Comment 5 Tammy Fox 2002-06-20 21:38:55 UTC
This patch works for me for multiple paras. 

I also would like to note that there is too much space if the listitem
contains an admonition (note, tip, warning, important, caution).

Comment 6 Tammy Fox 2002-07-03 05:48:18 UTC
Created attachment 63447 [details]
snippet to fix the extra space after a screen in a listitem

Comment 7 Tammy Fox 2002-07-03 05:51:02 UTC
I have attached a snippet of my custom stylesheet that I used to fix the
extra space after a screen inside a listitem. It is a 2 line change. I changed
the vspace definition and the space-before definition.

Comment 8 Tammy Fox 2002-07-13 23:38:57 UTC
Created attachment 65268 [details]
fix spacing after admon in listitem

Comment 9 Tammy Fox 2002-07-13 23:41:15 UTC
I have also attached a snippet that I changed from dbadmon.dsl to fix
the spacing after an admon in a listitem. As a bonus, notice the keep-with-next
additions -- they make sure the admon graphic and title are on the same page as
the content for the admon.


Note You need to log in before you can comment on or make changes to this bug.