Bug 661630 - id returns failure when nss_ldap uses TLS and oneshot nss_connect_policy
id returns failure when nss_ldap uses TLS and oneshot nss_connect_policy
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nss_ldap (Show other bugs)
5.5
All Linux
urgent Severity high
: rc
: ---
Assigned To: Nalin Dahyabhai
Ondrej Moriš
: Regression, Reopened, ZStream
Depends On: 613555
Blocks: 640580 662939
  Show dependency treegraph
 
Reported: 2010-12-09 04:25 EST by Ondrej Moriš
Modified: 2011-04-27 04:43 EDT (History)
3 users (show)

See Also:
Fixed In Version: nss_ldap-253-37.el5
Doc Type: Bug Fix
Doc Text:
Under certain circumstances, the nss_ldap module may have been unable to correctly process LDAP entries with a large number of group members. This was due to an error number being accidentally overwritten before the control was returned to the caller. When this happened, various utilities failed to produce expected results. With this update, this error has been fixed, the error number is no longer overwritten, and affected utilities now work properly.
Story Points: ---
Clone Of: 613555
Environment:
Last Closed: 2011-01-13 18:32:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 11 Jaromir Hradilek 2010-12-15 11:48:16 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Under certain circumstances, the nss_ldap module may have been unable to correctly process LDAP entries with a large number of group members. This was due to an error number being accidentally overwritten before the control was returned to the caller. When this happened, various utilities failed to produce expected results. With this update, this error has been fixed, the error number is no longer overwritten, and affected utilities now work properly.
Comment 13 errata-xmlrpc 2011-01-13 18:32:48 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0097.html

Note You need to log in before you can comment on or make changes to this bug.