This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 661779 - can't be rebuild in mock
can't be rebuild in mock
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-lxml (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Jiri Popelka
BaseOS QE - Apps
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-09 11:13 EST by Levente Farkas
Modified: 2015-10-05 10:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-05 10:31:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2010-12-09 11:13:53 EST
can't be rebuild in mock because of this error:

gcc -pthread -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasyn
chronous-unwind-tables -D_GNU_SOURCE -fPIC -fwrapv -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -
march=i686 -mtune=atom -fasynchronous-unwind-tables -fPIC -I/usr/include/libxml2 -I/usr/include/python2.6 -c src/lxml/lxml.etree.c -o build/temp.linux-i686-2
.6/src/lxml/lxml.etree.o -w
src/lxml/lxml.etree.c:4:20: error: Python.h: No such file or directory
src/lxml/lxml.etree.c:5:26: error: structmember.h: No such file or directory
src/lxml/lxml.etree.c:7:6: error: #error Python headers needed to compile C extensions, please install development version of Python.
error: command 'gcc' failed with exit status 1
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.Pdt6aD (%build)
    Macro % has illegal name (%define)
    Macro % has illegal name (%define)
    Bad exit status from /var/tmp/rpm-tmp.Pdt6aD (%build)
error: Macro % has illegal name (%define)
Comment 2 Jiri Popelka 2010-12-17 06:43:30 EST
diff -r1.5 python-lxml.spec
17,21c17,18
< %if 0%{?fedora} >= 8 || 0%{?rhel} >= 6               
< BuildRequires: python-setuptools-devel
< %else                                                      
< BuildRequires: python-setuptools                                     
< %endif                                                       
---                                                      
> BuildRequires:  python-devel
> BuildRequires:  python-setuptools
Comment 3 RHEL Product and Program Management 2011-01-07 10:32:55 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 4 RHEL Product and Program Management 2011-07-05 19:45:56 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 12 Steve Almy 2015-10-05 10:31:46 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux. We've carefully evaluated the request, but are unable to include it in a future release. To request that Red Hat re-consider this request, please re-open the bugzilla via your designated support representative and provide additional business and/or technical details.

Note You need to log in before you can comment on or make changes to this bug.