Bug 661933 - improvements to ACPI support
Summary: improvements to ACPI support
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-sensors-plugin
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-10 01:43 UTC by Raphael Groner
Modified: 2011-11-08 18:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-08 18:56:12 UTC
Type: ---


Attachments (Terms of Use)
Fix broken /proc/acpi/info link. (345 bytes, patch)
2010-12-10 01:45 UTC, Raphael Groner
no flags Details | Diff
Fix unit and device nodes for battery values (2.29 KB, patch)
2010-12-10 01:46 UTC, Raphael Groner
no flags Details | Diff
Correct default values for configure's help to the acpi options (1020 bytes, patch)
2010-12-10 14:04 UTC, Raphael Groner
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Xfce 6956 0 None None None Never
Xfce 6959 0 None None None Never
Xfce 6960 0 None None None Never

Description Raphael Groner 2010-12-10 01:43:32 UTC
Patches for upstream bug reports.
http://bugzilla.xfce.org/show_bug.cgi?id=6956
http://bugzilla.xfce.org/show_bug.cgi?id=6959

Comment 1 Raphael Groner 2010-12-10 01:45:15 UTC
Created attachment 467887 [details]
Fix broken /proc/acpi/info link.

Comment 2 Raphael Groner 2010-12-10 01:46:24 UTC
Created attachment 467888 [details]
Fix unit and device nodes for battery values

Comment 3 Raphael Groner 2010-12-10 01:50:47 UTC
Why is support for /sys/class/power_supply disabled in the Fedora package?

From http://kojipkgs.fedoraproject.org/packages/xfce4-sensors-plugin/1.0.0/1.fc14/data/logs/i686/build.log ...

checking for /sys/class/power_supply... no

It works here with my patch applied.

Comment 4 Raphael Groner 2010-12-10 13:43:05 UTC
The support for /sys/proc/power_supply can be strictly enabled with --enable-sysfsacpi=yes in configure, then it does not depend on the environment of the build system (different kernel).

Reported upstream as a bug in configure's help.
http://bugzilla.xfce.org/show_bug.cgi?id=6960

Comment 5 Raphael Groner 2010-12-10 14:04:38 UTC
Created attachment 467974 [details]
Correct default values for configure's help to the acpi options

Comment 6 Raphael Groner 2010-12-10 14:16:13 UTC
Comment on attachment 467974 [details]
Correct default values for configure's help to the acpi options

Run autoconf after applied the patch to apply changes also to configure itself.

Comment 7 Raphael Groner 2011-11-08 18:56:12 UTC
That seems to be patched in upstream.


Note You need to log in before you can comment on or make changes to this bug.