Bug 66196 - general: critical: name.c:923: ENSURE(name->labels <= 128) failed
general: critical: name.c:923: ENSURE(name->labels <= 128) failed
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-05 20:31 EDT by Kev 'Kyrian' Green
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-06 12:21:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kev 'Kyrian' Green 2002-06-05 20:31:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
Having followed the RedHatWatch list advisory and upgraded to BIND 9.2.1 (from 9.1.3) on a RedHat 7.2 system, the following error message appeared in my /var/log/named file, named died (as expected, given an assertion failure), and refused to restart (died again with the same failure, every time, even though I tried without any zones, and stuff like that):

general: critical: name.c:923: ENSURE(name->labels <= 128) failed


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Restart named.
2. Restart named again.
3. ... and again, ad infinitum.
 

Actual Results:  Still got the same problem, and was forced to downgrade as it's a production server.

Expected Results:  Name server should just have restarted as before without crashing.

Additional info:

No BIND configuration files or zone files included in this report
for customer confidentiality reasons, but if it will help, this information can be given to redhat in confidence (I know your Bugzilla system is accessible to the Internet, etc...).
Comment 1 Daniel Walsh 2003-01-06 12:21:20 EST
This looks like something is wrong in your data files.  It is indicating that
you have a nameserver record with greater than 128 labels.

Note You need to log in before you can comment on or make changes to this bug.