Bug 66201 - KDE applications like konqueror and konsole crash with this error report: "Unable to start dr. konqi".
KDE applications like konqueror and konsole crash with this error report: "Un...
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-06 00:05 EDT by jeffersontan
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:40:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jeffersontan 2002-06-06 00:05:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4.1) Gecko/20020314
Netscape6/6.2.2

Description of problem:
Upon attempting to start up konqueror or konsole, either on a shell or by
hitting the appropriate button, the application picked would start and, within
half a second or so, crash out. On a shell, the error would always be "Unable to
start dr. konqi."

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use the Control Center to update the locale and char set. Or use an editor to
edit ~/.kde/share/config/kdeglobals and edit the [Locale] block. A default
installation does not have this block, btw, so it's easier to have Control
Center do this for you.
2. Pick the 8859-8 character set.
3. Restart KDE.
	

Actual Results:  You can't start konsole or konqueror (and probably any other
application that starts up through kdeinit. When you try to start them up from
the shell, the error message above will appear (Unable to start dr. konqi).

Expected Results:  The application should start properly.

Additional info:

Through trial and error, I found that the problem was simply the use of the
8859-8 character set. If I modify it to iso8859-1 or iso10646-1, it works fine.

The funny thing is I don't remember EVER picking 8859-8 (for Hebrew characters).
The only thing I can think of is that I may have picked that character set by
mistake, although I doubt it as I have never had a reason to fiddle around with
the character set in the first place. Less likely possibilities (I'm reaching):
perhaps the Control Center picks a random character set if you don't supply one;
some other application modified the character set setting on 'kdeglobals',
perhaps while I was configuring it -- maybe korganizer, when I modified the
short date format? netscape or emacs, upon attempting to deal with input (email
or document) that had non-standard characters;  a leprechaun did it? :-)
Comment 1 Bernhard Rosenkraenzer 2002-06-10 11:33:38 EDT
I have no idea what caused this... Maybe Microsoft cracked your machine and 
did it to show that Linux applications can crash. ;) 
 
In any case, this is fixed in 7.3 and later. KDE 3.0 doesn't use a charset 
setting anymore (it builds a fake unicode charset from all available charsets, 
making it possible to display e.g. English, Chinese and Hebrew all in the same 
widget).
Comment 2 Bill Nottingham 2006-08-04 16:40:06 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.