Bug 66213 - up2date errors
up2date errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-06 08:42 EDT by Need Real Name
Modified: 2015-01-07 18:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 16:47:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-06 08:42:16 EDT
Description of Problem:up2date had a problem installing kernel-2.4.9-34


Version-Release number of selected component (if applicable):


How Reproducible:Only tried it once I ran up2date with the -u option on my system 48screamer.ggao.nasa.gov


Steps to Reproduce:
1.  up2date -u 
2. 
3. 

Actual Results:
[root@48screamer 7.1]# up2date -u

Retrieving list of all available packages...
########################################
########################################

Removing installed packages from list of updates...
########################################

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
########################################

Removing packages with files marked to skip from list...
########################################

Testing package set / solving RPM inter-dependencies...
########################################
Retrieving selected packages...
bind-utils-9.2.1-0.70.i386. ########################## Done.                   
ghostscript-6.51-16.1.7x.i3 ########################## Done.                   
kernel-2.4.9-34.i686.rpm:   ########################## Done.                   
kernel-headers-2.4.9-34.i38 ########################## Done.                   
Preparing...                ########################################### [100%]
   1:kernel-headers         ########################################### [ 25%]
   2:bind-utils             ########################################### [ 50%]
   3:ghostscript            ########################################### [ 75%]
   4:kernel                 ########################################### [100%]
Traceback (innermost last):
  File "/usr/sbin/up2date", line 1137, in ?
    main()
  File "/usr/sbin/up2date", line 388, in main
    sys.exit(batchRun(argObj.getLong("list"), pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 1116, in batchRun
    up2date.installBootLoader(kernelsToInstall)
  File "/usr/share/rhn/up2date_client/up2date.py", line 2357, in installBootLoader
    __install_lilo(kernelList)
  File "/usr/share/rhn/up2date_client/up2date.py", line 2376, in __install_lilo
    ret = lilocfg.installNewImages(kernelList,test=0)
  File "/usr/share/rhn/up2date_client/lilocfg.py", line 272, in installNewImages
    (default, tmptype, default_image,image_path,other,defaultIsOther) = findDefault(config,imagelist)
  File "/usr/share/rhn/up2date_client/lilocfg.py", line 213, in findDefault
    (imagetype, default_image,image_path,other) = config.getImage(default)
  File "/usr/share/rhn/up2date_client/lilo.py", line 140, in getImage
    raise IndexError, "unknown image %s" % (label)
IndexError: unknown image linux


Expected Results:
I have never had any problems with up2date in the past.  Is my kernel safe for rebooting?

Additional Information:
Comment 1 Adrian Likins 2002-06-13 16:29:57 EDT
Could I get a copy of you lilo.conf file?

it looks like there was possible a "default=" line in it
that pointed to a kernel image that didnt exist.

Does you lilo.conf have a kernel stanza with an
image of "linux"?
Comment 2 Adrian Likins 2004-04-05 16:47:37 EDT
Havent heard a response, so closing. 

Current releases should handle this better.

Note You need to log in before you can comment on or make changes to this bug.