Bug 66215 - Boot problem with latest errata kernel
Summary: Boot problem with latest errata kernel
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-06 13:19 UTC by adam.huffman
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 17:54:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description adam.huffman 2002-06-06 13:19:13 UTC
Description of Problem:
This kernel hangs at boot at the message "mxt_scan_bios: enter" unless APM
is enabled in the BIOS on an i850 m/b

Version-Release number of selected component (if applicable):
2.4.9-34

How Reproducible:
Every time

Steps to Reproduce:
1. Reboot machine
2. 
3. 

Actual Results:
Boot hangs

Expected Results:
Boot should proceed normally

Additional Information:

Comment 1 Arjan van de Ven 2002-06-06 13:21:47 UTC
Did 2.4.9-31 work?
What kind of CPU do you have ?

Comment 2 adam.huffman 2002-06-06 13:36:32 UTC
I have seen this with 2.4.9-31, albeit intermittently.  A couple of hard reboots
seemed to resolve it.

CPU is Pentium 4 1700:

cat /proc/cpuinfo 
processor
: 0
vendor_id
: GenuineIntel
cpu family	: 15
model
	: 0
model name	: Intel(R) Pentium(R) 4 CPU 1700MHz
stepping
: 10
cpu MHz		: 1694.869
cache size	: 256 KB
fdiv_bug
: no
hlt_bug
	: no
f00f_bug
: no
coma_bug
: no
fpu
	: yes
fpu_exception
: yes
cpuid level	: 2
wp
	: yes
flags
	: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush
dts acpi mmx fxsr sse sse2 ss ht tm
bogomips
: 3381.65

Comment 3 Arjan van de Ven 2002-06-06 13:42:36 UTC
Did 2.4.9-31 work?
What kind of CPU do you have ?

Comment 4 Ben LaHaise 2002-06-06 22:42:50 UTC
Hmmm, does booting with mem-nopentium have an effect?

Comment 5 Ben LaHaise 2002-06-06 22:43:49 UTC
make that mem=nopentium

Comment 6 adam.huffman 2002-06-10 12:58:12 UTC
That doesn't seem to make any difference.  In fact, while it happened three
times in a row when I reported it, I haven't been able to recreate the boot
failure since.

Comment 7 adam.huffman 2002-06-12 12:21:47 UTC
Because of another problem this morning I installed 2.4.19-pre10.  It hung in
the same place during bootup until I disabled APM support in the kernel
configuration.

Comment 8 Need Real Name 2002-06-27 15:33:07 UTC
I'm having a similar problem with 2.4.9-31 on an Intel CA810e MB.  It hangs at:

mxt_scan_bios: enter

But, ONLY if there is no keyboard attached.  

The BIOS of this machine lacks the ability to disable APM.

CPU is PIII-650MHz, Intel i810 chipset.

cat /proc/cpuinfo

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 1
cpu MHz         : 648.045
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat 
pse36 mmx fxsr sse
bogomips        : 1294.33

Any thoughts?

Comment 9 Alan Cox 2003-06-09 17:54:48 UTC
We removed mxt for several reasons, this problem included.



Note You need to log in before you can comment on or make changes to this bug.