Bug 66247 - Assertion failure in journal_commit_transaction() at commit.c:535: "buffer_jdirty(bh)"
Assertion failure in journal_commit_transaction() at commit.c:535: "buffer_jd...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Stephen Tweedie
Brian Brock
http://www.unix-scripts.com/err.txt
:
: 71562 74245 75289 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-06 15:07 EDT by Shaun Murphy
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-07 19:19:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shaun Murphy 2002-06-06 15:07:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Server Crash's, have to force reboot when comes back up this is the last error 
i see in the /var/log/messages.  Also this happenes with 2.4.18-3smp and 2.4.18-
4smp.  

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
It just randomly happens not sure what cause's it.  It likes to happen in the 
middle of the night though

Additional info:

Jun  6 02:51:46 occp2 kernel: Assertion failure in journal_commit_transaction() 
at commit.c:535: "buffer_jdirty(bh)"
Jun  6 02:51:46 occp2 kernel: ------------[ cut here ]------------
Jun  6 02:51:46 occp2 kernel: kernel BUG at commit.c:535!
Jun  6 02:51:46 occp2 kernel: invalid operand: 0000
Jun  6 02:51:46 occp2 kernel: iptable_filter ip_tables autofs eepro100 usb-ohci 
usbcore ext3 jbd 3w-xxxx sd_
Jun  6 02:51:46 occp2 kernel: CPU:    1
Jun  6 02:51:46 occp2 kernel: EIP:    0010:[<f883c0e4>]    Not tainted
Jun  6 02:51:46 occp2 kernel: EFLAGS: 00010286
Jun  6 02:51:46 occp2 kernel:
Jun  6 02:51:46 occp2 kernel: EIP is at journal_commit_transaction [jbd] 0xb04 
(2.4.18-3smp)
Jun  6 02:51:46 occp2 kernel: eax: 0000001c   ebx: 0000000a   ecx: c02eee60   
edx: 00003688
Jun  6 02:51:46 occp2 kernel: esi: f38465b0   edi: efb4e180   ebp: f3d1e000   
esp: f3d1fe78
Jun  6 02:51:46 occp2 kernel: ds: 0018   es: 0018   ss: 0018
Jun  6 02:51:47 occp2 kernel: Process kjournald (pid: 192, stackpage=f3d1f000)
Jun  6 02:51:47 occp2 kernel: Stack: f8842eee 00000217 00000000 00000000 
00000fb4 efc3d04c 00000000 f3e068e0
Jun  6 02:51:47 occp2 kernel:        f1837160 00001b57 00000286 00000286 
00000001 c2c2fee0 f2b06b60 f2740960
Jun  6 02:51:47 occp2 kernel:        f2a73f20 f367a240 f367a0c0 f0a88b40 
e75e7c00 e75ffd80 f2740960 e763a800
Jun  6 02:51:47 occp2 kernel: Call Trace: [<f8842eee>] .rodata.str1.1 [jbd] 
0x26e
Jun  6 02:51:47 occp2 kernel: [<c0119048>] schedule [kernel] 0x348
Jun  6 02:51:47 occp2 kernel: [<f883e7d6>] kjournald [jbd] 0x136
Jun  6 02:51:47 occp2 kernel: [<f883e680>] commit_timeout [jbd] 0x0
Jun  6 02:51:47 occp2 kernel: [<c0107286>] kernel_thread [kernel] 0x26
Jun  6 02:51:47 occp2 kernel: [<f883e6a0>] kjournald [jbd] 0x0
Jun  6 02:51:47 occp2 kernel:
Jun  6 02:51:47 occp2 kernel:
Jun  6 02:51:47 occp2 kernel: Code: 0f 0b 5a 59 6a 04 8b 44 24 18 50 56 e8 4b 
f1 ff ff 8d 47 48
Comment 1 Stephen Tweedie 2002-06-07 17:26:33 EDT
That is an oops from 2.4.18-3smp.  We know that this specific bug is possible in
2.4.18-3, and it is supposed to be fixed in 2.4.18-4.

If it is still happening on 2.4.18-4smp, then there must be something different
there from the original bug, and I really need an oops trace of the 2.4.18-4
crash to be able to debug it.  In all other reported cases, 2.4.18-4 does fix
this bug.
Comment 2 Shaun Murphy 2002-06-07 18:17:52 EDT
i have both kernels still on the server.  I left 2.4.18-3 on their just incase 
2.4.18-4 didnt work and it was set to default.  So sombody might have rebooted 
the machine and it would have booted on 2.4.18-3 then.  I set 2.4.18-4 to 
default.  Also why when you guys release kernel's do you not release a SMP 
kernel?
Comment 3 Stephen Tweedie 2002-06-07 18:45:09 EDT
We do, always.  There is a 2.4.18-4smp kernel just as there was a 2.4.18-3smp
kernel.  The kernel from your original bug report was an smp kernel.
Comment 4 Shaun Murphy 2002-06-07 19:19:36 EDT
n/m i'm just a idiot who doesnt look in the i686 dir :/  Thanks for your help 
guys and quick responce i will let you know if i see this error with 2.4.18-4.  
I'm really supprised with how fast you guys responded.  I figured i was going 
to have to wait months for a reply.
Comment 5 Stephen Tweedie 2002-06-08 07:08:18 EDT
No problem --- it's always easier for us to respond to bugs that are already
fixed, in any case.  :-)

I'll close this as fixed(ERRATA) for now, but please feel free to reopen it if
you see the problem on 2.4.18-4smp.

Comment 6 Stephen Tweedie 2002-08-15 05:39:37 EDT
*** Bug 71562 has been marked as a duplicate of this bug. ***
Comment 7 Stephen Tweedie 2002-09-18 13:08:38 EDT
*** Bug 74245 has been marked as a duplicate of this bug. ***
Comment 8 Stephen Tweedie 2002-10-07 04:28:53 EDT
*** Bug 75289 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.