Bug 66254 - self.setArrorCursor() typo in up2date
self.setArrorCursor() typo in up2date
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-06 15:56 EDT by Jim Wright
Modified: 2015-01-07 18:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-25 22:47:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Wright 2002-06-06 15:56:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
% /usr/sbin/up2date

Traceback (innermost last):
  File "/usr/share/rhn/up2date_client/gui.py", line 832, in doInstallation
    self.setArrorCursor()
AttributeError: setArrorCursor


Version-Release number of selected component (if applicable):
up2date-2.7.61-7.x.2


How reproducible:
Always

Steps to Reproduce:
1.% /usr/sbin/up2date

Additional info:

I presume that "self.setArrorCursor()" really ought to be "self.setArrowCursor()".

I believe everything worked and install was successful.  I got the latest kernel
and grub was updated (but not lilo, sigh).  however, the hourglass cursor is
still present on the gui which gives the impression that it crashed prior to
completion.
Comment 1 Jim Wright 2002-06-06 16:04:42 EDT
forgot to mention.  the gui is left with only the "cancel" button enabled.  the
back and next buttons are not enabled.  which furthers the impression that the
packages were not fully installed.  (but I think they were.)

% rpm -V kernel-source-2.4.9-34 kernel-doc-2.4.9-34 kernel-debug-2.4.9-34
kernel-2.4.9-34 kernel-headers-2.4.9-34
S.5....T   /boot/kernel.h-2.4.9

so yes, I think everything was installed fine.
Comment 2 jdalbec 2002-06-06 22:45:49 EDT
This typo is in the CommunicationError exception handler.  The last log message
I see says "Removing packages from package profile: [...]" so the
CommunicationError would have been raised in remoteDelPackages.  Could this be
related to the fact that the server disabled free service at about that time? 
Is there any way to "grandfather" currently running up2date sessions when that
happens?  Anyway, it looks like the packages installed successfully, but RHN
could not be notified of this fact.
Comment 3 Adrian Likins 2002-06-13 16:41:42 EDT
This (the typo) should be fixed in the next versions.


When the servers start throttling live users, it is
done at login time. Existing up2date sessions that
have valid authentication tokens should be fine
for the duration of the token time. 

It possible that a connnection was possibly
dropped at this time do to time outs. Generally
servers only get throttled when we are 100% bandwitdth
utilization, so it's possible.
Comment 4 Jim Wright 2002-10-25 22:47:44 EDT
I presume this can be closed.
Comment 5 Jim Wright 2002-12-03 15:26:50 EST
up2date-2.8.39-1.7.2 has this fixed

Note You need to log in before you can comment on or make changes to this bug.