Bug 66262 - internal gcc error on bad code involving STL and templates
internal gcc error on bad code involving STL and templates
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 66489 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-06 17:19 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 15:51:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-06 17:19:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
std::bind2nd(std::minus, 1.0) causes an internal compiler error. Ofcourse
template argument for std::minus is missing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.compile the following program  with g++ from gcc-2.96-110
#include<functional>
int main() {
  std::bind2nd(std::minus, 1.0);
}

	

Actual Results:  bug.cpp: In function `int main ()':
bug.cpp:4: Internal compiler error in expand_call, at calls.c:2250
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.


Expected Results:  message reporting a syntax error

Additional info:
Comment 1 Need Real Name 2002-06-11 09:42:43 EDT
*** Bug 66489 has been marked as a duplicate of this bug. ***
Comment 2 Alan Cox 2002-12-15 15:51:14 EST
Verified ok in 8.0 g++ 3.2

Note You need to log in before you can comment on or make changes to this bug.