Bug 66272 - EXT3 Error, Kernel Assertion Failure.
EXT3 Error, Kernel Assertion Failure.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-06 19:36 EDT by Uriah Welcome
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 13:48:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uriah Welcome 2002-06-06 19:36:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020531
Debian/1.0rc3-2

Description of problem:
The kernel from RedHat AS2.1 caused an EXT3 Error, which then seemed to kill any
process trying to access the filesystems.  I built the kernel RPM on a Redhat
7.2 System simply buy doing a 'rpm -ba --target=i686 src.rpm' or so.  The
machine is a Quad Xeon 700Mhz w/ 8GB of RAM and 2 Mylex RAID controllers.

Version-Release number of selected component (if applicable):
Linux usw-sf-db1 2.4.9-e.3enterprise #1 SMP Wed May 29 12:12:37 PDT 2002 i686
unknown

How reproducible:
Didn't try


Actual Results:  usw-sf-db1 kernel: Assertion failure in
journal_write_metadata_buffer() at journal.c:372: "buffer_jdirty(jh2bh(jh_in))"


Expected Results:  should have worked properly.

Additional info:

This machine is a large postgresql database server.
Comment 1 Larry Woodman 2003-06-23 13:16:15 EDT
The kswapd changes released in 2.4.9-e.12 fix this problem.

Larry Woodman
Comment 2 Suzanne Hillman 2003-10-02 14:43:52 EDT
Not sure if the original person who entered this bug has verified that it no
longer occurs, and I don't have enough information on how to reproduce it
myself, to make sure that it's gone.
Comment 3 Suzanne Hillman 2003-10-03 13:48:54 EDT
As it's been about three months since this was supposed to be fixed, with no
comments saying it's still broken, I'm closing this. If the problem still
exists, please reopen.

Note You need to log in before you can comment on or make changes to this bug.