Bug 66321 - libtiff-devel does not include private headers needed to build geotiff and other libraries and applications
libtiff-devel does not include private headers needed to build geotiff and ot...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: libtiff (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-07 13:15 EDT by Andrew Neuschwander
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-07 13:15:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Neuschwander 2002-06-07 13:15:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
libtiff-devel doesn't install 3 'private' header files: tiffiop.h, port.h, and
tif_dir.h

These header files are needed to build libgeotiff, and other applications such
as GDAL and the University of Mininnesota's MapServer.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install libtiff-devel
2.look in /usr/include for port.h, tif_dir.h, and tiffiop.h
3.Note that they are missing
	

Actual Results:  3 missing header files

Expected Results:  port.h, tif_dir.h, and tiffiop.h should have been installed
into /usr/include

Additional info:

This can be remedied with a simple change to the libtiff.spec file for building
the RPMS. Simple adding 'make install-private' just after 'make install' to the
build stage adds these files to the libtiff-devel.

Here is a patch to the spec file that adds a new libtiff-devel-private RPM:

*** libtiff.spec        Mon Feb 25 09:01:03 2002
--- libtiff.spec.new    Thu Jun  6 09:53:08 2002
***************
*** 1,7 ****
  Summary: A library of functions for manipulating TIFF format image files.
  Name: libtiff
  Version: 3.5.7
! Release: 2
  Copyright: distributable
  Group: System Environment/Libraries
  Source0: http://www.libtiff.org/tiff-v%{version}.tar.gz
--- 1,7 ----
  Summary: A library of functions for manipulating TIFF format image files.
  Name: libtiff
  Version: 3.5.7
! Release: 2.2an
  Copyright: distributable
  Group: System Environment/Libraries
  Source0: http://www.libtiff.org/tiff-v%{version}.tar.gz
***************
*** 40,45 ****
--- 40,59 ----
  image files, you should install this package.  You'll also need to
  install the libtiff package.

+ %package devel-private
+ Summary: The 'private' header files for libtiff.
+ Group: Development/Libraries
+ Requires: libtiff-devel = %{version}
+
+ %description devel-private
+ This package contains the 'private' header files: port.h, tiffiop.h,
+ and tif_dir.h which are used by several external packages including
+ PROJ.4 and libgeotiff
+
+ If you need to build or develop programs which use libtiff you may
+ need this package. You'll also need the libtiff and libtiff-devel
+ packages.
+
  %prep
  %setup -q -n tiff-v%{version}
  %patch0 -p1 -b .shlib
***************
*** 75,80 ****
--- 89,95 ----
  [ "$RPM_BUILD_DIR" ] && rm -fr $RPM_BUILD_ROOT
  mkdir -p $RPM_BUILD_ROOT/{%{_bindir},%{_includedir},%{_mandir}}
  make install
+ make install-private
  rm -f $RPM_BUILD_ROOT%{_libdir}/libtiff.so*
  install -m755 libtiff/libtiff.so.%{LIBVER} $RPM_BUILD_ROOT%{_libdir}
  ln -sf libtiff.so.%{LIBVER} $RPM_BUILD_ROOT%{_libdir}/libtiff.so
***************
*** 97,108 ****
  %files devel
  %defattr(-,root,root)
  %doc TODO html
! %{_includedir}/*
  %{_libdir}/libtiff.so
  %{_libdir}/libtiff.a
  %{_mandir}/man3/*

  %changelog
  * Mon Feb 25 2002 Phil Knirsch <pknirsch@redhat.com>
  - Fixed problem with newer bash versions setting CDPATH (#59741)

--- 112,136 ----
  %files devel
  %defattr(-,root,root)
  %doc TODO html
! %{_includedir}/tiff.h
! %{_includedir}/tiffconf.h
! %{_includedir}/tiffio.h
! %{_includedir}/tiffvers.h
  %{_libdir}/libtiff.so
  %{_libdir}/libtiff.a
  %{_mandir}/man3/*

+ %files devel-private
+ %defattr(-,root,root)
+ %{_includedir}/tiffiop.h
+ %{_includedir}/port.h
+ %{_includedir}/tif_dir.h
+
  %changelog
+ * Wed Jun 06 2002 Andrew Neuschwander <andrew@ntsg.umt.edu>
+ - Since everyone and their mom uses the 'private headers' have a
libtiff-devel-private
+   package to install these few headers.
+
  * Mon Feb 25 2002 Phil Knirsch <pknirsch@redhat.com>
  - Fixed problem with newer bash versions setting CDPATH (#59741)
Comment 1 Phil Knirsch 2002-06-19 03:56:27 EDT
I have pondered about this request for a long time (as you can seen by the long
NEW state it was in) and after discussing it with our folks here i've decided
not to include your request.

The reasons are the following:

 o If we include these header files in our packages, Red Hat Linux will
distribute an incompatible version of libtiff which might get used by other
software developers and in turn anger quite a few more.

 o This change sort of reflects a change in API as new functions are being
exposed via the new header files. This is something that absolutely should be
decided upstream by the official libtiff maintainers.

So in turn i'd like you to ask the official libtiff maintainers
(www.libtiff.org) to do this change upstream which we then in turn can and will
use here.

Sorry to deny this request.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.