Bug 66332 - Screen and keyboard locks up with slow mouse
Screen and keyboard locks up with slow mouse
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-07 19:08 EDT by Warren S
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-10 14:28:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config file (1.73 KB, text/plain)
2002-06-10 13:19 EDT, Warren S
no flags Details
Config file (12.36 KB, text/plain)
2002-06-10 13:29 EDT, Warren S
no flags Details
Log file (26.82 KB, text/plain)
2002-06-10 13:30 EDT, Warren S
no flags Details
Log file (28.92 KB, text/plain)
2002-06-10 13:31 EDT, Warren S
no flags Details

  None (edit)
Description Warren S 2002-06-07 19:08:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.3 (X11; Linux i686; U;) Gecko/20020523

Description of problem:
running rdesktop connecting to 2000 server and I get random lock ups.  Thought
it was the rdesktop program but then got the same while going to a different
console and then again by simply moving a desktop icon over a window looking for
a place to drop it.

The screen is locked as well as the keyboard.  The mouse moves but chugs like a
process is working hard.  SSHing in I can kill X and it will bring me back to a
X login screen but sometimes X will lock up there to.  I often don't see the
frame around the login box and just see the background go around buttons and
form boxes.  I usually will restart X if I see this and it fixes that.

Im using a Rage 128 SM/4x AGP 4x video card and not sure of the RAM.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.run rdesktop
2.login on the windows server
3.hit the start button or
browse the files with mycomputer
	

Actual Results:  mouse chugs and I discover I can't get to my hidden pannel or
use the keyboard.

Additional info:Tried several levels of resolution in Xconfigurator
Comment 1 Mike A. Harris 2002-06-10 00:32:06 EDT
What is rdesktop?  Never heard of it before.
Comment 2 Warren Togami 2002-06-10 01:25:23 EDT
http://www.rdesktop.org/

Open Source client to login to Windows Terminal Server.  I somehow doubt this is
the actual cause this problem.
Comment 3 Mike A. Harris 2002-06-10 03:59:17 EDT
I didn't imply that it was the cause of the problem.  I asked what it was
as I had no idea what it was.  Hard to frame a problem without having all
of the facts first.
Comment 4 Mike A. Harris 2002-06-10 04:17:23 EDT
Ok, I had a look at the rdesktop site.  Here are some potential things that
I can think of off the top of my mind:

1) Could possibly be a memory/resource leak in the X server

2) Could possibly be a memory/resource leak in rdesktop (since resources
   such as pixmaps are stored in the X server, it can appear to be an X
   server issue).

3) Could perhaps be a DRI and/or XAA issue perhaps.

Those are just a few guesses.  If you could provide the following additional
info, I can dig deeper:

What kernel are you using?  Please run:

uname -a
and
rpm -q --qf "%{name}-%{version}-%{release}.%{arch}\n" $(rpm -qa |grep kernel)

Please also attach your X server log, config file, and /var/log/messages from
right after a crash.

Also, can you run "top" in an xterm with 1 second updates (press s, then 1)
and sort by memory usage by pressing M.  Watch the output of top when the
problem occurs.  If it isn't reliable, try running top from another machine
via ssh, so you can see it die easily.  Does any particular process grow
in memory usage largely prior to the problem kicking in?  In particular
watch both the X process, and the rdesktop process(es).

Try disabling DRI by commenting out 'Load "dri"' in the config file, then
restart X.  Does this make the problem go away?

If you can provide the above details/info, etc. that could help debug the
problem.


Thanks.

Comment 5 Mike A. Harris 2002-06-10 06:05:08 EDT
One more thing I just thought of...  When it is "chugging", if you just
leave the machine alone for an extended length of time, does it eventually
stop, or does it crash, or perhaps hit an out-of-memory condition?

/var/log/messages will show OOM if that is occuring.  Also, how much RAM
is in the machine, and how much swap space.
Comment 6 Warren S 2002-06-10 13:19:39 EDT
Created attachment 60344 [details]
Config file
Comment 7 Warren S 2002-06-10 13:29:26 EDT
Created attachment 60364 [details]
Config file
Comment 8 Warren S 2002-06-10 13:30:51 EDT
Created attachment 60365 [details]
Log file
Comment 9 Warren S 2002-06-10 13:31:47 EDT
Created attachment 60366 [details]
Log file
Comment 10 Warren S 2002-06-10 13:51:01 EDT
I also had this happening in KghostView by moving the window after printing the
pdf document I was viewing.  

I have 255MB physical and 249 swap.

Linux PC20 2.4.18-4 #1 Thu May 2 18:06:25 EDT 2002 i686 unknown

kernel-2.4.18-4.athlon
kernel-2.4.18-3.athlon
kernel-source-2.4.18-4.i386

Watching top, I did not see X or rdesktop run away with memory.  I did see X run
away with cpu usage.  Also the mouse smooths out after killing some of the top
memory guzzlers such as Galeon/Mozilla.

Currently have not been able to make X crash after commenting the Load dri line
out; this may have fixed this problem. :)
Comment 11 Warren S 2002-06-10 14:28:30 EDT
No it does not eventually stop, crash or hit an out-of-memory condition.

Note You need to log in before you can comment on or make changes to this bug.