Bug 66341 - cups ssl setup could be better (and default)
cups ssl setup could be better (and default)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-08 03:19 EDT by Joshua Jensen
Modified: 2008-02-27 06:49 EST (History)
0 users

See Also:
Fixed In Version: F-8
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 06:49:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2002-06-08 03:19:39 EDT
Description of Problem:

1)  What could be better than a service that can use SSL?  Answer:  one that
uses SSL by default.  Why not make CUPS use HTTPS by default?

2)  Also, as /etc/cups/ssl/{server.crt,server.key} is mentioned in cupsd.conf,
shouldn't /etc/cups/ssl at least exist?  Once it exists, why not issue in the
rpm's %postinstall script:

ln -s /etc/httpd/conf/ssl.crt/server.crt /etc/cups/ssl/server.crt
ln -s /etc/httpd/conf/ssl.key/server.key /etc/cups/ssl/server.key


Perhaps in the next version of RHL, one or both of these small changes could be
made.

Thank you,

Joshua
Comment 1 Joshua Jensen 2002-10-01 17:01:59 EDT
CUPS is a beautiful thing.  Making it even better is good too.
Comment 2 Tim Waugh 2002-10-11 07:36:09 EDT
You want cups to depend on httpd?
Comment 3 Joshua Jensen 2002-10-11 10:35:45 EDT
Hmmm... you are right, we can't count on the certs to be there.  I guess cups
should just make it's own then.
Comment 4 Joshua Jensen 2004-09-24 13:52:21 EDT
ping... ?  Should we close this Tim?
Comment 5 Tim Waugh 2004-09-27 04:12:05 EDT
Er.. if you like, but SSL is not the default at the moment.
Comment 6 Joshua Jensen 2004-09-27 12:06:17 EDT
Ok... but is it even a possibility?  If not, please close the case...
if so, any ETA on it?
Comment 7 Tim Waugh 2004-09-27 12:27:55 EDT
It would certainly be nice to have.  ETA is very difficult to say,
because this is a feature compared to all the bugs lying around, and
so is quite low priority.

I'll close it DEFERRED for the time being, because it certainly won't
be in FC3.

Note You need to log in before you can comment on or make changes to this bug.