Bug 66355 - Installer recognizes compaq diagnostics partition as swap and aborts
Installer recognizes compaq diagnostics partition as swap and aborts
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-08 08:15 EDT by Moody Ahmad
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Moody Ahmad 2002-06-08 08:15:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510

Description of problem:
I am installing RH7.3 on a compaq deskpro with a 200 MHz PPro. There is a 2 block
partition on hda for compaq diagnostics. It is of partition type 12. However,
the step following fdisk setup, the installer insists that
it is a swap partition. I verified several time with fdisk that the partition
type is 12. I also tried changing the partition type to DOS and a few other
values. However, the installer sees that 2 block partition only as swap. I then
select don't format as I don't want to lose that partition. The installer then
dies saying it couldn't use that partition. I do have a 300MB swap partition on
hda2. However, that does not keep the installer from aborting. So, for the
moment I solved the problem by deleting the 2 block compaq diagnostics partition
and that is working right now. However, it would be good if you could fix this
bug. Please contact me if you need any more information.

Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1.Start installation on disk with 2 block compaq diagnostics partition on hda1
(ide drive)
2.Select don't format option for this partition
3.installer will abort
	

Actual Results:  description says it all

Additional info:
Comment 1 Michael Fulbright 2002-06-10 12:54:34 EDT
Assigngin to an engineer.
Comment 2 Jeremy Katz 2002-06-10 14:06:07 EDT
When it aborts, does it give a traceback?  Could you attach that to this bug
report?  Also, if you run parted on the drive, does it recognize the partition
as swap?
Comment 3 Moody Ahmad 2002-06-10 22:04:53 EDT
When it aborts, there is stuff that flashes by on the screen. When I try and
reboot, it just hangs. So, I don't have access to the traceback. Is there a way
to get the traceback? I haven't run parted on the drive, however, anaconda seems
to think it is swap even when I change it to various other partition types.
Fdisk interprets the partition type correctly each time.
I had a similar problem with another system I was installing. The disk had a
single linux partition (ext2), however anaconda thought it was swap till I went
into edit and changed it format it as ext3. Seems like there is some problem
with anaconda not recognizing partition types correctly.
Comment 4 Jeremy Katz 2002-06-12 14:55:08 EDT
We use parted as our partitioning backend, hence why I wanted to verify that it
was parted misinterpreting.  Note that parted actually does probing of the
filesystem instead of just looking at the numeric ID because the numeric IDs in
DOS partition tables are not conclusive and can regularly be misleading.
Comment 5 Michael Fulbright 2002-07-15 12:52:47 EDT
Closing due to inactivty, please reopen if you have additional information to add.
Comment 6 Red Hat Bugzilla 2006-02-21 13:49:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.