Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 663638 - kio/ mediamanger's HAL backend does not honor mount options set in HAL config files
Summary: kio/ mediamanger's HAL backend does not honor mount options set in HAL config...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdebase
Version: 5.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Than Ngo
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 743405
TreeView+ depends on / blocked
 
Reported: 2010-12-16 13:12 UTC by ritz
Modified: 2018-11-14 16:06 UTC (History)
3 users (show)

Fixed In Version: kdebase-3.5.4-26
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-20 07:21:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch based on upstream code (2.43 KB, patch)
2010-12-16 13:12 UTC, ritz
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1177 0 normal SHIPPED_LIVE kdebase bug fix update 2012-08-20 11:20:03 UTC

Description ritz 2010-12-16 13:12:29 UTC
Created attachment 469133 [details]
patch based on upstream code

Description of problem:
KDE mediamanager HAL backend relies on it's own config file rather than using information obtained from HAL itself. This is wrong - HAL provides an universal way to set up mount points, options etc easy obtainable through libhal. and there is no benefits of using mediamangerrc for all of these. Moreover, mediamangerrc is incomplete - for instance, it does not correctly handle all mount options (just to mention: iocharset and codepage) which draws it almost useless when you have non-English system with non-UTF locale: there is no way to specify the correct charset and all non-Latin characters become unreadable.

Reproducible: 
always

Steps to reproduce:
1. setup device permission
 
$ cat /etc/hal/fdi/policy/removable-drive.fdi 
<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
<!-- for removable disks containing partitions -->
<deviceinfo version="0.2">
  <device>
    <match key="@info.parent:storage.removable" bool="true">
      <match key="@info.parent:storage.removable.media_available" bool="true">
        <merge key="storage.policy.mount_option.ro" type="bool">true</merge>
        <merge key="volume.policy.mount_option.ro" type="bool">true</merge>
      </match>
    </match>
  </device>
</deviceinfo>


2. Start KDE and mount some media
3. Check "mount" option

Expected result
ro mount option for removable disks

Actual result:
rw mounts


Additional information:
Upstream bug - http://bugs.kde.org/show_bug.cgi?id=133456
The patch attached to upstream works. ( http://bugs.kde.org/attachment.cgi?id=20368 )

Comment 13 errata-xmlrpc 2012-08-20 07:21:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1177.html


Note You need to log in before you can comment on or make changes to this bug.