This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 663658 - Additional support/testing for booting RHEVH from SD card devices
Additional support/testing for booting RHEVH from SD card devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhev-hypervisor6 (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-16 09:29 EST by Perry Myers
Modified: 2016-04-26 10:42 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Red Hat Enterprise Virtualization Hypervisor now supports installation to a wider range of Secure Digital (SD) cards. Installation to this larger set of SD cards is in addition to the already fully supported use of locally attached SATA hard disk drives and fibre-channel-attached LUNs. RHEV-H continues to be fully supported for boot and installation from the following devices: USB thumbdrives, Secure Digital cards, and CDROM (both physical and virtual). It is also supported via PXE boot.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 14:06:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2010-12-16 09:29:21 EST
Description of problem:
Presently it is supported to install RHEVH onto USB flash disks and solid state hard disks.  These are all treated as standard SCSI block devices via /dev/sdX device nodes.

Certain SD card readers are not exposed via standard drivers.  Some may work in RHEL and some might need additional driver work to work properly.

We need additional testing from baseos kernel team on which devices we can support in RHEL and then testing from RHEVH team on deploying RHEVH on these supported SD devices.
Comment 16 Andrew Cathrow 2011-08-26 10:45:19 EDT
we should have the ability to install to : sd, local sata, fc lun and install from USB, SD, CDROM, PXE and ISO
Comment 19 Mike Burns 2011-09-12 15:02:56 EDT
I've looked at 2 different card readers that I have available beyond the one I used previously.  Both are USB card readers like the ones you are using.  I've successfully installed from USB stick to SD card and from SD card to USB stick using both these readers.  

The issue you're reporting sounds a lot like one of the install issues that we were hitting in other bugs that have been fixed.  Can you try again with the latest RHEV-H build?

Thanks

Mike
Comment 20 Mike Burns 2011-09-12 15:06:57 EDT
My testing was done using 6.2-0.16.2.el6 and an IOGEAR Model GUH287 reader and a Rosewill RCR-IC002 reader.
Comment 28 Zac Dover 2011-10-23 23:24:06 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Red Hat Enterprise Virtualization Hypervisor now features the ability to install to DS, local SATA, FC LUN. It can also install from USB, SD, CDROM, PXE and ISO.
Comment 29 Mike Burns 2011-10-24 07:29:17 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Red Hat Enterprise Virtualization Hypervisor now features the ability to install to DS, local SATA, FC LUN. It can also install from USB, SD, CDROM, PXE and ISO.+Red Hat Enterprise Virtualization Hypervisor now features the ability to install to SD, local SATA, FC LUN. It can also install from USB, SD, CDROM, PXE and ISO.
Comment 30 Perry Myers 2011-10-24 09:25:00 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1,5 @@
-Red Hat Enterprise Virtualization Hypervisor now features the ability to install to SD, local SATA, FC LUN. It can also install from USB, SD, CDROM, PXE and ISO.+Red Hat Enterprise Virtualization Hypervisor now supports being installed to a wider range of Secure Digital (SD) cards.
+
+Installation to this larger set of SD cards is in addition to the already fully supported use of locally attached SATA hard disk drives and fibre channel attached LUNs.
+
+RHEVH continues to be fully supported for boot/install from the following devices: USB thumbdrives, Secure Digital cards, CDROM (both physical and virtual) and via PXE boot.
Comment 31 Alan Pevec 2011-10-25 06:58:46 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -2,4 +2,4 @@
 
 Installation to this larger set of SD cards is in addition to the already fully supported use of locally attached SATA hard disk drives and fibre channel attached LUNs.
 
-RHEVH continues to be fully supported for boot/install from the following devices: USB thumbdrives, Secure Digital cards, CDROM (both physical and virtual) and via PXE boot.+RHEV-H continues to be fully supported for boot/install from the following devices: USB thumbdrives, Secure Digital cards, CDROM (both physical and virtual) and via PXE boot.
Comment 33 Zac Dover 2011-12-06 03:10:27 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,5 +1,5 @@
-Red Hat Enterprise Virtualization Hypervisor now supports being installed to a wider range of Secure Digital (SD) cards.
+Red Hat Enterprise Virtualization Hypervisor now supports installation to a wider range of Secure Digital (SD) cards.
 
-Installation to this larger set of SD cards is in addition to the already fully supported use of locally attached SATA hard disk drives and fibre channel attached LUNs.
+Installation to this larger set of SD cards is in addition to the already fully supported use of locally attached SATA hard disk drives and fibre-channel-attached LUNs.
 
-RHEV-H continues to be fully supported for boot/install from the following devices: USB thumbdrives, Secure Digital cards, CDROM (both physical and virtual) and via PXE boot.+RHEV-H continues to be fully supported for boot and installation from the following devices: USB thumbdrives, Secure Digital cards, and CDROM (both physical and virtual). It is also supported via PXE boot.
Comment 34 errata-xmlrpc 2011-12-06 14:06:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html

Note You need to log in before you can comment on or make changes to this bug.