Bug 66381 - nsupdate missing in bind-utils-9.2.1-0.70
nsupdate missing in bind-utils-9.2.1-0.70
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-09 09:26 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-11 10:30:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-09 09:26:43 EDT
Description of Problem:





The man page is there, but the executable is missing:











# rpm -p bind-utils-9.2.1-0.70.i386.rpm -ql | grep nsupdate





/usr/share/man/man8/nsupdate.8.gz











Note that nsupdate was included in the bind-utils package that shipped with 7.1:











# rpm -p bind-utils-9.1.0-10.i386.rpm -ql | grep nsupdate





/usr/bin/nsupdate





/usr/share/man/man8/nsupdate.8.gz











Version-Release number of selected component (if applicable):














How Reproducible:














Steps to Reproduce:




1. Freshen bind-utils to version 9.2.1-0.70.





2. Attempt to run /usr/bin/nsupdate





Actual Results:





bash: /usr/bin/nsupdate: No such file or directory










Expected Results:









nsupdate output.





Additional Information:
Comment 1 Bernhard Rosenkraenzer 2002-06-10 08:15:13 EDT
The binary has moved to the bind package because some people running 
workstations without any need to control a DNS server complained about the 
"useless" tool in bind-utils. 
 
The fact that the man page is still in bind-utils is a bug.
Comment 2 Enrico Scholz 2002-06-11 10:29:27 EDT
Why shall I install the server package to get 'nsupdate'? It is completely
independent of the server; some systems broke here on the last bind-errate
because 'nsupdate' was used but only bind-utils installed.

IMO bind-utils was the perfect place for this tool, but to satisfy the people
named by you, please add a new package 'bind-nsupdate' where nsupdate is within!
Comment 3 Karsten Hopp 2002-07-22 11:38:05 EDT
Let people complain about a few kb more in bind-utils. It's better than 
breaking scripts. nsupdate and the man page are now back in bind-utils

Note You need to log in before you can comment on or make changes to this bug.