Bug 66392 - Large files truncated durring cp or mv. Errors out
Summary: Large files truncated durring cp or mv. Errors out
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i586
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-09 21:37 UTC by Tim R. Even
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-10 13:50:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim R. Even 2002-06-09 21:37:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
hdc: ATAPI reset complete
end-request: I/O error, dev 16 (hdc) sectory 17552
cp: reading 'scheme-7.7.0-ix86-hnu-linux.tar.gz' Input/output error

Turning off DMA, autoseek, etc. does not fix

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cp <16542KB file on CD-ROM> to root on hard drive
2.
3.
	

Actual Results:  ...
hdc: ATAPI reset complete
end-request: I/O error, dev 16 (hdc) sectory 17552
cp: reading 'scheme-7.7.0-ix86-hnu-linux.tar.gz' Input/output error

Part of the file is copied, but not all of the file. I can copy the complete 
file - where it passes md5sum - in XP.


Expected Results:  I should have been able to copy this file from a CD-ROM to 
my hard drive so I can install the application for which I purchased the O.S..

Additional info:

Lite-On LTN-486 CD-ROM on Dell Dimension 4400 dual booting with XP Pro and 
Linux.

Comment 1 Bernhard Rosenkraenzer 2002-06-10 07:54:46 UTC
hdc: ATAPI reset complete  
end-request: I/O error, dev 16 (hdc) sectory 17552  
  
indicates either a hardware problem or a bug in the IDE chipset driver. 
 
While it's much more likely to be a hardware problem, I'm assigning this to 
the kernel for further investigation.

Comment 2 Arjan van de Ven 2002-06-10 08:07:07 UTC
What kernel is this? What hardware ?

Comment 3 Tim R. Even 2002-06-10 13:50:44 UTC
Thank you very much for your help. Turns out that I had a bad block on the CD-
ROM disk, which is what the error messages were telling me.  Sorry, I should 
have caught that one!


Note You need to log in before you can comment on or make changes to this bug.