Bug 66395 - rpm query via FTP fails
rpm query via FTP fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-09 18:56 EDT by Binand Sethumadhavan
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-09 18:56:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Binand Sethumadhavan 2002-06-09 18:56:12 EDT
Description of Problem:

rpm query via FTP fails on RedHat 7.2 (and possibly others).

Version-Release number of selected component (if applicable):

rpm version: 4.0.3-1.03

How Reproducible:

Always

Steps to Reproduce:

trying to query (didn't try to install) an RPM via FTP, I get this:

binand@binand[~]:(8) rpm -qp -vv 
ftp://ftp.redhat.com/pub/redhat/redhat-7.3-en/os/i386/RedHat/RPMS/fetchmail-5.9.0-5.i386.rpm
D: logging into ftp.redhat.com as ftp, pw (username)
error: open of 
ftp://ftp.redhat.com/pub/redhat/redhat-7.3-en/os/i386/RedHat/RPMS/fetchmail-5.9.0-5.i386.rpm 
failed: Success

Whereas:
lftp ftp.redhat.com:/pub/redhat/redhat-7.3-en/os/i386/RedHat/RPMS> ls 
fetchmail-5.9.0-5.i386.rpm
-rw-r--r--    1 19837    19837      429566 Apr 17 04:19 
fetchmail-5.9.0-5.i386.rpm

Actual Results:

Though other FTP clients succeed in getting the file (I tried wget/lftp), rpm's
internal FTP handling failed.

Expected Results:

It should have succeeded :)

Additional Information:

Default installation of RedHat 7.2, behind an ipchains SNAT gateway on a 
private network. The man page of RPM mentions FTP transfers are always PASV, 
so this shouldn't be an issue.
Comment 1 Jeff Johnson 2002-06-10 05:12:20 EDT
This problem has been fixed since Red Hat 7.2
was released. Try rpm-4.0.4 packages from Red Hat
7.3.

Note You need to log in before you can comment on or make changes to this bug.