Bug 664000 - Anaconda does not let you choose hostname during the install if not specified in ks file
Anaconda does not let you choose hostname during the install if not specified...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-17 12:40 EST by Peter Ryzhenkov
Modified: 2013-06-28 15:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-17 13:10:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ryzhenkov 2010-12-17 12:40:02 EST
Description of problem:
Anaconda does not let you choose hostname during the non-interactive install if it's not specified in kickstart file.


Steps to Reproduce:
1. Do not put a hostname in a kickstart file
2. Start a kickstart installation
  
Actual results:
Anaconda skips the hostname step that appears during the non-ks (ordinary) install. It ends up assigning 'localhost' hostname after the installation.

Expected results:
Anaconda should ask for a hostname if none was specified in the kickstart file.
Comment 1 Peter Ryzhenkov 2010-12-17 12:48:27 EST
<a href="https://bugzilla.redhat.com/attachment.cgi?id=291413&action=diff">There's a fix submitted for RHEL</a>. Please backport it:
Comment 2 Chris Lumens 2010-12-17 13:10:51 EST
The hostname is given as part of the network command.  The network command is optional - you do not strictly need to configure networking to have a usable system.  As such, kickstart cannot tell whether it needs to stop and prompt for network information.  Is it missing because you forgot to put it in, or is it missing because you didn't want networking at all?
Comment 3 Peter Ryzhenkov 2010-12-17 13:34:02 EST
or is it missing because you didn't want networking at all?
> strange to hear that in the year 2010.

I may be wrong, but this thing makes it impossible to perform kickstart based software rollouts on multiple machines with the same software configuration but different hostnames. What's your solution for such a case? Make a separate CD/DVD for each and every computer? Nonsense.

Why the RHEL and CentOS developers do think it's a bug and let you configure system the way you want?

The best way IMO is to put something like 'network --bootproto=query' as on CentOS or do not skip the hostname screen if there's nothing said about that in ks file.

I insist it's a bug.
Comment 4 Chris Lumens 2010-12-17 13:41:44 EST
> > or is it missing because you didn't want networking at all?
> strange to hear that in the year 2010.

And yet people want this all the time.

> I may be wrong, but this thing makes it impossible to perform kickstart based
> software rollouts on multiple machines with the same software configuration but
> different hostnames. What's your solution for such a case? Make a separate
> CD/DVD for each and every computer? Nonsense.

Specify network --bootproto=dhcp and have your DHCP server hand out hostnames.  NetworkManager should preserve this on the running system.

> Why the RHEL and CentOS developers do think it's a bug and let you configure
> system the way you want?

I *am* the RHEL developer too.  The patch you're referring to is way back from RHEL5, and things are significantly different now.  Please refer to the migration guide:

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Migration_Planning_Guide/ch02s02s02.html
Comment 5 Peter Ryzhenkov 2010-12-17 14:13:58 EST
>And yet people want this all the time.

Never heared of them.

>Specify network --bootproto=dhcp and have your DHCP server hand out hostnames. 
>NetworkManager should preserve this on the running system.

Why can't you just make it simply ask for a hostname if none was specified in kickstart and it was not sent by a DHCP server. What if there's no DHCP server around (these things still do happen)? What if I have Dynamic DNS in my office (I do have it for some clients) that asks for a hostname to assign a DHCP lease instead of giving it? I can give you a thousand reasons. This solution is very inflexible.
Comment 6 Peter Ryzhenkov 2010-12-19 11:10:48 EST
Chris, will you please tell me what do I do in case of DDNS/DHCP server configuration?

How do the words you've said above fit with this statement made by you as well?
>Note that this only applies to use of the "interactive"
>command.  Omitting information from a kickstart file will still cause anaconda
>to stop and prompt for it.
https://bugzilla.redhat.com/show_bug.cgi?id=581218#c7

Thanks in advance!
Comment 7 locohost 2013-06-28 15:42:46 EDT
I 100% agree with Peter Ryzhenkov and It saddens me that Redhat would think so little their user community as to insult them by suggesting such a silly solution.  They DHCP route may work in some situations, but yeah, I can think of many where it would not work, including my environment.

network --bootproto=query just makes so much sense.  Please fix this bug.

Note You need to log in before you can comment on or make changes to this bug.