Bug 66489 - g++ gives internal error when compiling template code with syntax errors.
g++ gives internal error when compiling template code with syntax errors.
Status: CLOSED DUPLICATE of bug 66262
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-06-11 06:19 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-06-11 06:19:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-11 06:19:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
Try compiling this code:
int main() {
  std::bind2nd(std::minus, 1.0);  

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Compile the code in the description (I'm using 2.96-110)

Actual Results:  [he@marel2023 he]$ g++ -c bug.cpp 
bug.cpp: In function `int main ()':
bug.cpp:3: Internal compiler error in expand_call, at calls.c:2250
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

Additional info:

I tried submitting this bug before.. but can't find it in bugzilla nor have I
got a confirmation email. Hope this is not a duplicate.
Comment 1 Need Real Name 2002-06-11 09:42:49 EDT
this is a duplicate of 66262

*** This bug has been marked as a duplicate of 66262 ***

Note You need to log in before you can comment on or make changes to this bug.