Bug 665042 - Periodical system freezes
Summary: Periodical system freezes
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 14
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-22 14:20 UTC by Jiri Pirko
Modified: 2018-04-11 19:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-16 16:39:17 UTC
Type: ---


Attachments (Terms of Use)
Xorg log (34.85 KB, text/plain)
2010-12-22 14:20 UTC, Jiri Pirko
no flags Details
Xorg.0.log (210.75 KB, text/plain)
2010-12-22 15:47 UTC, Jiri Pirko
no flags Details
dmesg_before_issue (124.09 KB, text/plain)
2010-12-22 15:48 UTC, Jiri Pirko
no flags Details
dmesg_after_issue (124.05 KB, text/plain)
2010-12-22 15:49 UTC, Jiri Pirko
no flags Details
/var/log/messages (2.41 MB, text/plain)
2010-12-22 15:50 UTC, Jiri Pirko
no flags Details


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 29536 0 None None None Never

Description Jiri Pirko 2010-12-22 14:20:17 UTC
Created attachment 470209 [details]
Xorg log

Description of problem:

Every ~15-20 secs The system freezes for ~100-400 ms. I noticed that on mouse cursor.

Version-Release number of selected component (if applicable):
kernel-2.6.35.9-64.fc14.x86_64
xorg-x11-drv-intel-2.12.0-6.fc14.1.x86_64
xorg-x11-server-Xorg-1.9.3-3.fc14.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install F14 from live CD on Thinkpad T61 with intel graphics
2. Boot up
3. Connect external monitor via DVI
  
Actual results:
freezes appear

Expected results:
freezes do not appear

Additional info:
I tried current upstream kernel 2.6.37-rc7+. There, the situation is better but yet still I experience some freezes (shorter and not so often).

I tried to boot runlevel 3 and run only xinit. Same behaviour there.

Comment 1 Matěj Cepl 2010-12-22 15:22:09 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Most of the fun in Xorg currently is in kernel, so /var/log/Xorg.0.log is useful, but only with limited value. Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command AFTER the issue happens but BEFORE restart, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Jiri Pirko 2010-12-22 15:47:38 UTC
Created attachment 470219 [details]
Xorg.0.log

Comment 3 Jiri Pirko 2010-12-22 15:48:58 UTC
Created attachment 470220 [details]
dmesg_before_issue

Comment 4 Jiri Pirko 2010-12-22 15:49:29 UTC
Created attachment 470221 [details]
dmesg_after_issue

Comment 5 Jiri Pirko 2010-12-22 15:50:42 UTC
Created attachment 470222 [details]
/var/log/messages

Comment 6 Jiri Pirko 2010-12-22 15:51:28 UTC
I have no xorg.conf file.

Comment 7 Jiri Pirko 2011-01-06 15:37:32 UTC
Anything else I can do? The issue is starting to annoy me more and more.

Comment 8 Michal Schmidt 2011-01-07 13:58:03 UTC
Perhaps you did not stress this important detail enough:

> 3. Connect external monitor via DVI

i.e. The freezes are only happening as long as an external monitor is connected to the laptop. That's why the suspicion fell on xorg-x11-drv-intel, right?

Do the freezes go away if the "poll=0" parameter is used for the drm_kms_helper module?

Comment 9 Jiri Pirko 2011-01-07 14:20:48 UTC
(In reply to comment #8)
> Perhaps you did not stress this important detail enough:
> 
> > 3. Connect external monitor via DVI
> 
> i.e. The freezes are only happening as long as an external monitor is connected
> to the laptop. That's why the suspicion fell on xorg-x11-drv-intel, right?
> 
> Do the freezes go away if the "poll=0" parameter is used for the drm_kms_helper
> module?

Yes, poll=0 makes the freezes go away.

Comment 10 Michal Schmidt 2011-01-07 14:22:04 UTC
Looks like https://bugs.freedesktop.org/show_bug.cgi?id=29536 then.

Comment 11 Wayne Hammond 2011-01-12 00:51:18 UTC
My computer has been partially freezing for some months now.  By partially freezing, I can open applications sometimes, but sometimes the application is only partially available, cannot navigate between buttons, some or perhaps all buttons unresponsive, clicking does nothing, buttons do not change when mouse passes over them.  Menus items on the desktop are usually normal with drop down lists opening normally.  Sometimes another application can be opened, but after one application is open I usually cannot open another (most of the time the application is Firefox or Chrome).  If I succeed in opening an application, the screen locks entirely most of the time.  I just purchased a new video card in the hopes the card was at issue with the same results.

I have reinstalled the OS twice and the problem seems to go away after a fresh install, but soon returns during a software upgrade.  I am losing all of my links during the OS reinstalls.

My hardware is an MSI motherboard, intel i7 920 processor, 6 GByte memory, 1 TB SATA HD.

Help!

Comment 12 Jiri Pirko 2011-01-12 07:36:42 UTC
Wayne, that sounds like a completely different issue.

Comment 13 Wayne Hammond 2011-01-12 22:16:11 UTC
Jiri, Perhaps it is.  Should I open a new ticket?  In addition to what I described above, when I cannot access a screen early on, it seems to be a mouse issue.  I cannot access anything inside the on screen application (buttons are inactive) but I can tab between items and activate with the enter key.  The menu items on main menu bar can be accessed with the mouse and other applications opened.  I have to do a new OS install to return the system to a normal operational mode.  The Automatic Bug Reporting Tool does not see any bugs.

Also, I've had this issue with two different computers, an Asus 
g73J Laptop and a MSI motherboard Intel i7 920 processor and an ATI 5570 Graphics card.

Comment 14 Jiri Pirko 2011-01-13 08:13:54 UTC
(In reply to comment #13)
> Jiri, Perhaps it is.  Should I open a new ticket?

yes.

Comment 15 Fedora End Of Life 2012-08-16 16:39:20 UTC
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.