Bug 665594 - ISO images changing ownerships to qemu:qemu when installing virtual machine
ISO images changing ownerships to qemu:qemu when installing virtual machine
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
16
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-25 04:08 EST by Nikolai Maziashvili
Modified: 2013-01-09 18:27 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 15:10:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikolai Maziashvili 2010-12-25 04:08:42 EST
Description of problem:
When i try to install virtual machine from downloaded iso image which has my (user) ownerships KVM changes those ownerships to qemu:qemu. What leaves me with iso image in my home dir that doesn't belong to me. I mean ,yeah it's not a big deal one might say i still can remove file, but i do think it is a bug.
KVM/QEMU has no business modifying ownerships of files in my home dir.

Version-Release number of selected component (if applicable):
my system:
Fedora 14 2.6.35.10-72.fc14.x86_64
QEMU emulator version 0.13.0 (qemu-kvm-0.13.0)

How reproducible:


Steps to Reproduce:
1. Fire up virt-manager
2. choose iso image from your disk as install source
3. begin installation. not until this point ownerships are changed.
4. you may quit installation. at this point ownerships are changed already
  
Actual results:


Expected results:


Additional info:
If any additional info required will be happy to provide it
Comment 1 Nikolai Maziashvili 2011-08-29 14:39:57 EDT
Will any action be taken on this one? At least tell me that it's not a bug but a feature. 
Doses every one besides me think that it is alright for qemu to hijack file ownership? Why it can't just read them, these files are world readable.
Comment 2 Nikolai Maziashvili 2011-08-29 14:41:24 EDT
Reassigning this bug to Fedora 15. In F15 i have to deal with the same issue.
Comment 3 Fedora Admin XMLRPC Client 2011-09-22 13:54:07 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-09-22 13:58:03 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-11-30 15:05:12 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-11-30 15:05:25 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2011-11-30 15:09:05 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Admin XMLRPC Client 2011-11-30 15:09:18 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Cole Robinson 2012-06-07 15:10:33 EDT
qemu:///system, which is what virt-manager uses, runs libvirtd as root, and qemu processes as the qemu owner. Changing storage files to be owned by qemu:qemu prevents non authorized users from touching those files.

So this is expected behavior, it's a security mechanism of libvirt. If you want to disable it, set turn off dynamic_ownership in /etc/libvirt/libvirtd.conf and restart libvirtd.

You can try using the libvirt qemu:///session URI which auto launches a libvirtd daemon as a regular user, but the it's not as well tested so you may hit other issues.

Note You need to log in before you can comment on or make changes to this bug.