Bug 66569 - megaraid install hang with 4kb stripe size
megaraid install hang with 4kb stripe size
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-12 07:29 EDT by masanari iida
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 14:49:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description masanari iida 2002-06-12 07:29:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
HP NetRAID-1M/2M with 4k byte stripe size cause following errors.

Blocked mailbox......!! 
SCSI timeout

Then system hang.  Default stripe size (64kb) is OK.
Use older megaraid (1.15hp), it works fine.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create 4kb stripe size LU on NetRAID 1M/2M
2. Install RH7.3 from CD-ROM
3. 
	

Actual Results:   Install never finish because of errors.
 Blocked mailbox.....!! scsi timeout


Expected Results:   Finish install.


Additional info:

 This problem went into megaraid source code between version 1.15 (1.15hp) and 1.18.
The workaround that we found was, use default stripe size or bigger.
Comment 1 Arjan van de Ven 2002-06-12 07:31:09 EDT
LSI has informed us that a 4Kb stripe size is not supported well with their
firmware. We have had a LOT of problems with 4Kb sizes before, and it has costed
us dearly. It is an official recommendation to NOT use 4Kb stripes with AMI/LSI
megaraid (and OEM variants) hardware.
Comment 2 masanari iida 2002-06-12 08:02:16 EDT
OK, if 4kb is not recommended or not supported, my next question is,
which stripe size is recommended & supported.
I remember the default of the stripe size is 64kb.
And I would like to know which stripe size has tested by LSI or RedHat?

Comment 3 Arjan van de Ven 2003-06-07 14:49:44 EDT
LSI fixed the firmware;.

Note You need to log in before you can comment on or make changes to this bug.