Bug 66570 - Bad default TeX directory in auctex config
Bad default TeX directory in auctex config
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-12 07:49 EDT by diego.santacruz
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-23 16:07:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description diego.santacruz 2002-06-12 07:49:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
The configuration of the auctex package has a default value for TeX-macro-global
which is /usr/local/lib/texmf/tex/.
Since redhat installs tex in /usr/share/texmf/tex/ the default should be set to
match that, so that no special fiddling is needed for a standard installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install xemacs and tetex
2.
3.
	

Actual Results:  By default the auctex package is not aware of tex's location in
a default redhat install.

Expected Results:  auctex should be aware of were redhat's default installation is.

Additional info:

One has to manually include something like:
(defvar TeX-macro-global '("/usr/share/texmf/tex/")
  "*The TeX installation directory, where to find site wide style files.")
in the tex-site.el file to solve this.
A proper fix would be probably to change the default in
/usr/lib/xemacs/xemacs-packages/lisp/auctex/tex.el
Comment 1 Trond Eivind Glomsrxd 2002-06-12 16:18:50 EDT
What problem do you see, and how do you reproduce it? Auc-tex-mode seems to work
well for (although with a slightly newer version).
Comment 2 diego.santacruz 2002-06-13 03:12:38 EDT
If you call (from within XEmacs) the TeX-auto-generate-global command, XEmacs
will not be able to find the TeX/LaTeX macro files if that path is not correctly
set.
Comment 3 Jens Petersen 2002-11-11 21:52:30 EST
This is already fixed in tex-site.el in xemacs-21.4.8-16.

Note You need to log in before you can comment on or make changes to this bug.