This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 665770 - Parallel build not correctly enabled.
Parallel build not correctly enabled.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: patch (Show other bugs)
rawhide
All All
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-26 15:54 EST by Moritz Barsnick
Modified: 2011-01-04 08:04 EST (History)
1 user (show)

See Also:
Fixed In Version: patch-2.6.1-6.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-04 08:04:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2010-12-26 15:54:03 EST
Description of problem:
Parallel build of the package is not correctly enabled.

Version-Release number of selected component (if applicable):
2.6.1-5

How reproducible:
Always on more than one CPU.

Steps to Reproduce:
1. Build package.
2. Observe %build stage.
  
Actual results:
make

Expected results:
make -j2 (or similar, depending in no. of CPUs)

Additional info:
http://fedoraproject.org/wiki/PackagingGuidelines#Parallel_make

The cause is the mistyped macro usage %{?smp_mflags} instead of %{?_smp_mflags}.

The change log for Mon Dec  3 2007 (2.5.4-31) claims to have added support for parallel build. Apparently, nobody has noticed yet. ;-)
Comment 1 Tim Waugh 2011-01-04 08:04:53 EST
Thanks!

Note You need to log in before you can comment on or make changes to this bug.