Bug 665800 - missing glyph symbol shown when toggling bold/italic for Sinhala text
missing glyph symbol shown when toggling bold/italic for Sinhala text
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
rawhide
Unspecified Linux
low Severity urgent
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
: 665803 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-27 00:03 EST by Danishka Navin
Modified: 2011-10-27 08:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-27 08:06:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample file with missing glyph symbol (8.24 KB, application/vnd.oasis.opendocument.text)
2011-01-13 11:05 EST, Danishka Navin
no flags Details
Sample pdf file with missing glyph symbol (1.54 KB, application/pdf)
2011-01-13 11:06 EST, Danishka Navin
no flags Details
fonts info (426.14 KB, application/octet-stream)
2011-01-13 11:57 EST, Danishka Navin
no flags Details
some groping towards a solution (16.41 KB, patch)
2011-10-25 11:22 EDT, Caolan McNamara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 32665 None None None Never

  None (edit)
Description Danishka Navin 2010-12-27 00:03:19 EST
Description of problem:

To reproduce

01: Open the writer
02: press CTRL+Space and enable iBus
03: type some Sinhala characters 
04: Bold or Italic part of the Sinhala text

You can notice that some the text you intended to bold converting to boxes
instead of bold/italic text. 

earlier we there was no boxes when we change text formatting to Bold, Italic 


Version-Release number of selected component (if applicable):

 OO.org latest build for Fedora 14 
OOO330m17

 
Actual results:

Expected results:

Additional info:

Two solutions:

A: 

Highlight those boxes, and select the LKLUG ( Sinhala font) from the font list

B:

 Tools > Options > Languages

Set the CTL value from 'Hindi' to 'none'  

due to this bug we can't use writer for day to day work.
Comment 1 Caolan McNamara 2010-12-29 15:32:25 EST
*** Bug 665803 has been marked as a duplicate of this bug. ***
Comment 2 Caolan McNamara 2010-12-29 15:44:00 EST
Sounds like glyph substitution problems really, with a font that doesn't have true bold/italic variants so they need faking up and something is going awry.

What's the font, and what's the locale, and give me some sample text.

i.e. 

a) output of "locale"
b) and what does it say in format->character under "CTL font" when the error exists
c) and some sample text ?, would it be possible to just create a document which displays the error and attach it here

For me locally if I launch from a si_LK locale then I already get LKLUG as my default font, and turning on bold/italic works fine. Launching from hi_IN and I get Lohit Devanagari as my default font, and bold/italic apparently works as well with that font.
Comment 3 Caolan McNamara 2011-01-13 04:52:40 EST
I can't reproduce this, so I'll have to close this bug.

I'm sure the bug still exists, so please attach a document which reproduces this for you when the text is toggled bold/italic. And the other requested information would be helpful too and feel free to reopen then.
Comment 4 Danishka Navin 2011-01-13 07:12:14 EST
I have tested in en-US after configuring iBus Sinhala.

but this will work if you select LKLUG font at least for a one time this issue wont appear again..

Btw...

one of following actions will fix it temporally

01. Easiest way:
 Enable iBus
 Change the font to LKLUG (or any Sinhala Unicode font)

you have to fix this only once per account
 


02.

Tools > Options > Languages

Set the CTL value from 'Hindi' to 'none'

*CTL – Complex Text Layout
Comment 5 Caolan McNamara 2011-01-13 07:35:19 EST
I need a route to reproduce it, not a route to make it go away. 

When it is broken what font is shown in format->character, is it a secret :-). If you can just attach a document which is broken for you that might help a great deal.
Comment 6 Danishka Navin 2011-01-13 11:01:43 EST
Font = DejaVu Sans Condensed
Format = Bold or/and Italic
Comment 7 Danishka Navin 2011-01-13 11:05:35 EST
Created attachment 473357 [details]
Sample file with missing glyph symbol

attached the odt ile with missing glyph symbol
Comment 8 Danishka Navin 2011-01-13 11:06:37 EST
Created attachment 473358 [details]
Sample pdf file with missing glyph symbol

attached the pdf file with missing glyph symbol
Comment 9 Caolan McNamara 2011-01-13 11:49:43 EST
still can't reproduce this, attach the output of 

fc-list -v > /tmp/allfontinfo

Most probably an edge case in glyph substitution. If the text was set to its correct language, that'd probably fix it too.
Comment 10 Danishka Navin 2011-01-13 11:57:55 EST
Created attachment 473372 [details]
fonts info

attached the font info file
Comment 11 Caolan McNamara 2011-01-14 07:22:23 EST
Aha, gnu-free-serif-fonts is the trigger. Reproducible now.
Comment 12 Caolan McNamara 2011-01-14 07:35:38 EST
puke, FreeSerif provides a bold and italic version of the font, but while the non-bold/non-italic fonts have the required glyphs, the bold and italic ones don't. Sigh.
Comment 13 Caolan McNamara 2011-01-14 08:30:56 EST
Hmm, everything is set up to assume that a Bold/Italic font has the same glyphs as its default variant.
Comment 14 Caolan McNamara 2011-10-25 11:22:27 EDT
Created attachment 530122 [details]
some groping towards a solution
Comment 15 Caolan McNamara 2011-10-27 08:06:25 EDT
fix will be in 3.4.4.1-3.f17

Note You need to log in before you can comment on or make changes to this bug.