Bug 665893 - pairing not permanent
pairing not permanent
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-27 13:56 EST by entwanzer
Modified: 2012-08-16 15:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 15:42:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description entwanzer 2010-12-27 13:56:31 EST
Description of problem:
pairing of a bluetooth keyboard works but the pairing process has to be redone every time the keyboard is powered off and on or respectively goes in and out powersave mode. The bluetooth keyboard is a secondary keyboard, there is also a usb-keyboard connected to the machine.

Version-Release number of selected component (if applicable):
Name        : blueman
Arch        : x86_64
Version     : 1.21
Release     : 6.fc14


How reproducible:
always

Steps to Reproduce:
1. keyboard is unknown to the system, not paired or anything
2. switch keyboard into discoverable mode
3. search for bluetooth devices, the keyboard is found
4. select the keyboard, click on "Setup". A random number is shown on the screen, type the number on the bluetooth keyboard
5. select "connect to Input service"
6. a dialogue says pairing successful
7. A popup shows up below the clock applet and says "pairing request, enter pin" (this popup does not seem to come from within blueman"
8. click on "enter pin" 
9. Enter a pin of your choice e.g. "0000" with your usb-keyboard
10. Enter the same pin on the bluetooth keyboard
11. check that the bluetooth keyboard is working
11. switch off bluetooth keyboard
12. wait for 10 seconds
13. switch on bluetooth keyboard
14. continue with step 7.

  
Actual results:
you have to go through steps 7-14

Expected results:

no further steps after step 6

Additional info:

Keyboard: Logitech Cordless MediaBoard Pro
Bluetooth-dongle: Belkin bluetooth adapter
smolt-profile: http://www.smolts.org/client/show/pub_ecdcdba5-27cf-46ef-910d-bb11fe9118ca
Comment 1 entwanzer 2011-01-11 12:34:12 EST
I tried the same procedure with another bluetooth-dongle and everything worked fine.
Why does the pairing depend on the dongle? I assumed the pairing information would be stored on the PC and not the dongle.

The bluetooth adapter that causes the Problem is a BELKIN Model: F8T017
Comment 2 entwanzer 2011-01-30 10:40:46 EST
seems to be a driver problem
Comment 3 Fedora End Of Life 2012-08-16 15:42:05 EDT
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.