Bug 665929 - [abrt] evolution-2.32.1-1.fc14: PK11_DestroySlot: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
Summary: [abrt] evolution-2.32.1-1.fc14: PK11_DestroySlot: Process /usr/bin/evolution ...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b4cbabd701b572745c032ad2814...
: 665346 714464 729360 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-28 01:03 UTC by Pedro Silva
Modified: 2011-08-10 06:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-06 10:45:37 UTC


Attachments (Terms of Use)
File: backtrace (62.42 KB, text/plain)
2010-12-28 01:03 UTC, Pedro Silva
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 638808 None None None Never

Description Pedro Silva 2010-12-28 01:03:55 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: evolution
component: evolution
crash_function: PK11_DestroySlot
executable: /usr/bin/evolution
kernel: 2.6.35.10-72.fc14.i686.PAE
package: evolution-2.32.1-1.fc14
rating: 4
reason: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1293497778
uid: 500

How to reproduce
-----
1. Open Evolution
2. Work for 10 hours
3. Close Evolution and Crash

Comment 1 Pedro Silva 2010-12-28 01:03:57 UTC
Created attachment 470895 [details]
File: backtrace

Comment 2 Milan Crha 2011-01-06 10:45:37 UTC
Thanks for a bug report. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=638808

Thread 1 (Thread 2510):
#0  0x02cd65ab in PK11_DestroySlot (slot=0x88d5df8) at pk11slot.c:434
#1  0x02cd664d in PK11_FreeSlot (slot=0x88d5df8) at pk11slot.c:464
#2  0x02cf5e0a in nssDecodedPKIXCertificate_Destroy (dc=0xaeb9f508) at pki3hack.c:549
#3  0x02cf28d5 in nssDecodedCert_Destroy (dc=0xaeb9f508) at certdecode.c:92
#4  0x02ced416 in nssCertificate_Destroy (c=0xab59d168) at certificate.c:162
#5  0x02ced4be in NSSCertificate_Destroy (c=0xab59d168) at certificate.c:182
#6  0x02ce980c in CERT_DestroyCertificate (cert=0xab595a10) at stanpcertdb.c:753
#7  0x03707b62 in smime_cert_data_free (cert_data=0xab595a10) at camel-smime-context.c:85
#8  0x036d1fb3 in ccv_certinfo_free (info=0xabc44d18) at camel-cipher-context.c:432
#9  0x036d3add in camel_cipher_validity_free (validity=0xaeb98800) at camel-cipher-context.c:638
#10 0x03937129 in emf_free_cache (efc=0xaeb9dba8) at em-format.c:83
#11 0x00ce3c80 in g_hash_table_remove_all_nodes (hash_table=0x8ae3660 = {...}, notify=1) at ghash.c:491
#12 0x00ce46fe in g_hash_table_remove_all (hash_table=0x8ae3660 = {...}) at ghash.c:1169
#13 0x00ce479e in g_hash_table_destroy (hash_table=0x8ae3660 = {...}) at ghash.c:876
#14 0x03938631 in emf_finalize (object=0x8605120 [EMFormatHTMLDisplay]) at em-format.c:150
#15 0x03897e3c in efh_finalize (object=0x8605120 [EMFormatHTMLDisplay]) at em-format-html.c:615
#16 0x0023713c in g_object_unref (_object=0x8605120) at gobject.c:2695
#17 0x038622df in mail_display_dispose (object=0x8acb0e0 [EMailDisplay]) at e-mail-display.c:178

Comment 3 Milan Crha 2011-01-06 12:10:31 UTC
*** Bug 665346 has been marked as a duplicate of this bug. ***

Comment 4 Milan Crha 2011-06-20 06:15:58 UTC
*** Bug 714464 has been marked as a duplicate of this bug. ***

Comment 5 Milan Crha 2011-08-10 06:58:59 UTC
*** Bug 729360 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.