Bug 66625 - plaympeg segfaults when attempting to play non-existent file
Summary: plaympeg segfaults when attempting to play non-existent file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: smpeg   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-12 18:25 UTC by msterret
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-12 20:53:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description msterret 2002-06-12 18:25:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
/usr/bin/plaympeg segfaults if the file it's requested to play
on the command-line doesn't exist.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. /usr/bin/plaympeg crashme

	

Actual Results:  $ /usr/bin/plaympeg crashme
mcop warning: user defined signal handler found for SIG_PIPE, overriding
crashme: Couldn't open crashme
Fatal signal: Segmentation Fault (SDL Parachute Deployed)


Expected Results:  $ /usr/bin/plaympeg crashme
mcop warning: user defined signal handler found for SIG_PIPE, overriding
crashme: Couldn't open crashme
$

Additional info:

$ rpm -qf `ldd /usr/bin/plaympeg | sed 's/.*> //; s/ .*//'` | sort -u
glibc-2.2.5-34
SDL-1.2.3-7
smpeg-0.4.4-9
XFree86-libs-4.2.0-8

Comment 1 Ngo Than 2002-06-12 20:06:43 UTC
It's fixed in smpeg-0.4.4-12. You find it in next rawhide release.

Comment 2 msterret 2002-06-12 20:50:28 UTC
$ rpm -q smpeg
smpeg-0.4.4-12
$ rpm -qf /usr/bin/plaympeg 
smpeg-0.4.4-12
$ /usr/bin/plaympeg --version
SDL version: 1.2.3
SMPEG version: 0.4.3
$ /usr/bin/plaympeg crashme 
mcop warning: user defined signal handler found for SIG_PIPE, overriding
crashme: Couldn't open crashme
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

Comment 3 msterret 2002-06-12 20:53:04 UTC
Looks like it's still broken to me.  Could you try the one in rawhide
and let me know if it still works for you?  I'm also curious about the
SMPEG version: 0.4.3 thing.  I think it should be 0.4.4...

Comment 4 Ngo Than 2002-06-13 09:03:59 UTC
sorry, 0.4.4-12 does includes this fix. I mean 0.4.4-13, it should fix this bug.
Please try it again.


Note You need to log in before you can comment on or make changes to this bug.