Bug 666326 - evolution - crash in comp_subject
evolution - crash in comp_subject
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
: Patch
Depends On: 664329 666843 666916 883010
Blocks: 782183
  Show dependency treegraph
 
Reported: 2010-12-30 00:54 EST by Siddharth
Modified: 2014-02-02 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version: evolution-2.32.3-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 03:41:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
backtrace, disassembly (55.29 KB, text/plain)
2010-12-30 00:56 EST, Siddharth
no flags Details
sosreport (359.66 KB, application/x-xz)
2010-12-30 00:56 EST, Siddharth
no flags Details
patch based on upstream code (2.66 KB, patch)
2011-01-03 14:12 EST, ritz
mcrha: review+
Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 597567 None None None Never

  None (edit)
Description Siddharth 2010-12-30 00:54:32 EST
Description of problem:
abrt version: 1.1.13
Attached file: backtrace
cmdline: evolution
component: evolution
executable: /usr/bin/evolution
kernel: 2.6.32-71.7.1.el6.x86_64
reason: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
time: 1291169422
uid: 500 

Version-Release number of selected component (if applicable):
evolution-2.28.3-10.el6
Red Hat Enterprise Linux Workstation release 6.0 (Santiago)

How reproducible:
Random crash

Steps to Reproduce:
1.
  
Actual results:
Evolution killed.

Expected results:
Evolution should not killed.

Additional info:
Comment 1 Siddharth 2010-12-30 00:56:06 EST
Created attachment 471144 [details]
backtrace, disassembly
Comment 2 Siddharth 2010-12-30 00:56:46 EST
Created attachment 471145 [details]
sosreport
Comment 4 ritz 2011-01-03 14:12:42 EST
Created attachment 471540 [details]
patch based on upstream code

prereq - eds and libical to be patched ( check bz blocks )
Comment 6 Milan Crha 2011-01-17 05:22:35 EST
Comment on attachment 471540 [details]
patch based on upstream code

I'm not sure of the first chunk, but otherwise it seems like a copy of the upstream patch, so feel free to use it. When the libical update will be done, and evolution rebuilt against it, then the fix will work.
Comment 11 RHEL Product and Program Management 2011-07-05 20:22:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 13 RHEL Product and Program Management 2012-12-14 01:51:15 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 15 Milan Crha 2013-05-09 13:38:27 EDT
Upstream fix is part of 2.32.3, thus I mark this as a dependency to the rebase bug.
Comment 16 Milan Crha 2013-06-10 08:36:44 EDT
I would close this bug as obsolete, there is nothing to change on evolution side, except of rebuild against newer libical, if any. Once the rebuild will happen, the change included in 2.32.3 will start working.
Comment 17 Milan Crha 2013-06-27 03:41:54 EDT
Closing due to comment #15, once the libical will be updated, and the evolution rebuilt against it, then the included fix will start working.

Note You need to log in before you can comment on or make changes to this bug.