Bug 66641 - PCMCIA not detecting i82365 chip properly in beta
PCMCIA not detecting i82365 chip properly in beta
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: 67217 79578
  Show dependency treegraph
 
Reported: 2002-06-12 16:22 EDT by David Lawrence
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 17:34:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2002-06-12 16:22:27 EDT
Description of Problem:
Intel PCIC controller properly detected in 7.3 is no longer being detected
properly for latest Milan beta. I have an external pcmcia controller device that
uses an ISA card to add PCMCIA support to a standard desktop that I use for
PCMCIA testing with beta's. It worked fine during and after install with 7.3.
Current beta's using 2.4.18-5.47 no longer are able to detect a PCIC. I was told
 by installer team that it was a kernel issue.

Here is the installer output on VC3 when it gets to the part about detecting 
PCIC controllers:

* in startPcmcia()
* pcmcia probe returned: | PCI bridge proble: not found
Intel PCIC probe: not found
Databook TCIC-2 probe: not found
|
* no pcic controller found

I am attaching dmesg output and /etc/sysconfig/pcmcia output to this report
from a working 7.3 install with the same card in it.

Version-Release number of selected component (if applicable):
kernel-2.4.18-5.47
Milan-re0612.nightly
Comment 1 David Lawrence 2002-06-12 16:25:05 EDT
Jun 12 15:35:12 glen kernel: Linux Kernel Card Services 3.1.22
Jun 12 15:35:12 glen kernel:   options:  [pci] [cardbus] [pm]
Jun 12 15:35:12 glen kernel: Intel PCIC probe:
Jun 12 15:35:12 glen kernel:   Intel i82365sl B step ISA-to-PCMCIA at port 0x3e0
ofs 0x00,+2 sockets
Jun 12 15:35:12 glen kernel:     host opts [0]: none
Jun 12 15:35:12 glen kernel:     host opts [1]: none
Jun 12 15:35:12 glen kernel:     ISA irqs (scanned) = 3,4,5,7 polling interval =
1000 ms
Jun 12 15:35:12 glen gpm: gpm startup succeeded
Jun 12 15:35:13 glen kernel: cs: IO port probe 0x0c00-0x0cff: clean.
Jun 12 15:35:13 glen kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x290-0x297
+0x378-0x37f 0x4d0-0x4d7
Jun 12 15:35:13 glen kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Jun 12 15:35:13 glen kernel: cs: memory probe 0x0d0000-0x0dffff: excluding
0xd0000-0xd3fffJun 12 15:35:13 glen kernel: cs: memory probe 0x0c0000-0x0cffff:
excluding 0xc0000-0xcffffJun 12 15:35:13 glen kernel: xirc2ps_cs.c 1.31
1998/12/09 19:32:55 (dd9jn+kvh)
Jun 12 15:35:13 glen kernel: eth1: MII link partner: 01e1
Jun 12 15:35:13 glen kernel: eth1: MII selected
Jun 12 15:35:13 glen kernel: eth1: media 100BaseT, silicon revision 0
Jun 12 15:35:13 glen kernel: eth1: Xircom: port 0x300, irq 3, hwaddr
00:10:A4:E0:0A:1F
Jun 12 15:35:13 glen kernel: ttyS03 at port 0x02e8 (irq = 3) is a 16550A
Jun 12 15:35:13 glen kernel: eth1: MII link partner: 01e1
Jun 12 15:35:13 glen kernel: eth1: MII selected
Jun 12 15:35:13 glen kernel: eth1: media 100BaseT, silicon revision 0


PCMCIA=yes
PCIC=i82365
PCIC_OPTS=
CORE_OPTS=

Comment 2 Arjan van de Ven 2002-07-11 07:47:32 EDT
Ok this is funky, the i82365 code actually hasn't changed a lot ;(
Trying to revert the small (and should-be-innocent) change for 2.4.18-5.68
Comment 3 Arjan van de Ven 2002-07-31 09:11:28 EDT
does it work in limbo2?
Comment 4 David Lawrence 2002-08-26 12:18:46 EDT
Nope. Still does not detect properly. Also tried it with the latest
Milan-re0826.nightly and it is not detected. Is detected properly in 7.3. Here
is the output on VC2 in the 7.3 installer.

* in startPcmcia()
* pcmcia probe returned: |PCI bridge probe: not found
Intel PCIC probe: i82365sl B step found, 2 sockets
|
* need to load i82365
* modules to insert pcmcia_core
* module(s) pcmcia_core not found
* load module set done 
* failed to load pcmcia_core --ask for pcmciadd
Comment 5 Bill Nottingham 2003-02-11 01:22:26 EST
Dave, is this working these days?
Comment 6 Bill Nottingham 2003-02-19 17:34:10 EST
This was a kernel-pcmcia-cs bug. Since fixed.

Note You need to log in before you can comment on or make changes to this bug.