Bug 66660 - iproute2 rule support in the ifup config script system.
Summary: iproute2 rule support in the ifup config script system.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-13 07:11 UTC by Edward Rudd
Modified: 2014-03-17 02:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 03:29:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
network-scripts patch to add iproute2 functionality via static-routes2 (1.24 KB, patch)
2002-06-18 19:04 UTC, Edward Rudd
no flags Details | Diff

Description Edward Rudd 2002-06-13 07:11:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020607

Description of problem:
have the ifup scripts handle more of the iproute2 functionality.. specifically
ip rule and using the extra routing tables. This is needed if one has two
external Internet interfaces (cable modem and isdn)
for now I have a rc.local run script running
ip rule add from {ETH1 IP} table eth1.out
ip route add default scope global via {ETH1 GW} table eth1.out
ip rule add from {ETH2 IP} table eth2.out
ip route add default scope global via {ETH2 GW} table eth2.out

where eth1.out and eth2.out are aliased in the /etc/iproute2/rt_tables



Version-Release number of selected component (if applicable):
6.67-1

How reproducible:
Always

Steps to Reproduce:
N/A

Comment 1 Edward Rudd 2002-06-18 19:04:00 UTC
Created attachment 61449 [details]
network-scripts patch to add iproute2 functionality via static-routes2

Comment 2 Edward Rudd 2002-06-18 19:11:02 UTC
the attached patch adds an extra script in the netw-work-scripts directory
ifup-routes2 and patches ipup-post to run ifup-routes2 after ipup-routes

the format of the static-routes2 file is 
$DEVICE ${IP_ARGS}

and the script greps command for the device it is "upping"

mine looks like this (ip addresses altered for security)
isdn.out is added to /etc/iproute2/rt_tables and assigned an unused number.
as is cable.out
--static-routes2--
eth2 rule add from {ip for eth2} table isdn.out
eth2 route add default scope global via {gateway for eth2} table isdn.out
eth1 rule add from {ip for eth1} table cable.out
eth1 route add default scope global via {gateway for eth1} table cable.out
----
now traffic can come in both external interfaces and go back out the correct
interface.. instead of being lost in kernel land..



Note You need to log in before you can comment on or make changes to this bug.