Bug 66664 - Missing kernel-2.4.*.i586.rpm package
Missing kernel-2.4.*.i586.rpm package
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-13 05:56 EDT by Dmitry Bolkhovityanov
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 14:48:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Bolkhovityanov 2002-06-13 05:56:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
The kernel for i586 architecture is missing from the distribution.
When installing on a Pentium machine, the i386 kernel is installed, which is
definitely inoptimal.  The only .i586 is kernel-smp, which isn't the best choice
for usual machines, and isn't installed anyway.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RHL-7.3 on an i586 machine.
2.Do "rpm -qi kernel|grep Size"
3.Do "rpm -qip <PATH_TO_DIST>i386/RedHat/RPMS/kernel-2.4.18-3.i386.rpm|grep Size"
	

Actual Results:  
Size        : 29228505                         License: GPL
Size        : 29228505                         License: GPL

Expected Results:  Obviously that must be something different.

Additional info:

That problem was already present in 7.2 (but *not* in 7.1).  While the absence
of .i486 kernel is tolerable, there are lots of Pentium machines, which will
live for long time.

Maybe the problem is that "rpm -ba --target i586 kernel-2.4.spec" builds  only
kernel-smp, but not regular kernel package.
Comment 1 Arjan van de Ven 2003-06-07 14:48:46 EDT
errata kernels have added this kernel back

Note You need to log in before you can comment on or make changes to this bug.