Bug 66667 - LPRng reports a new error in /var/log/messages that it didn't before.
LPRng reports a new error in /var/log/messages that it didn't before.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-13 08:32 EDT by Bill Barnes
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 09:01:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Barnes 2002-06-13 08:32:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Ever since I ran up2date and got that LPRng update, I've been getting the 
following message in /var/log/messages 

Jun 12 15:37:49 piscon (Server)[16869]: floor21: Open_gdbm: cannot 
lock 'db.floor21' - Interrupted system call
 
This is a new error for me.  Any ideas what this this?  It sometimes hangs the 
print queue up and gets stalled, other times, it doesn't seem to cause any 
problems.




Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Go to end user workstation.
2.Print something large.
3.Go to another end user workstation, and submit another job while first is 
printing.
	

Expected Results:  I expect it to work as before, just queue up and print, 
without any error messages in the /var/log/messages file.


Additional info:
Comment 1 Tim Waugh 2002-07-17 05:49:42 EDT
Just to confirm the version numbers here: LPRng-3.6.24-2 (which came on the CD)
worked fine, but LPRng-3.7.4-23.1 doesn't?

There have been two updates to LPRng.  The first was 3.6.24-2-to-3.7.4-23, a
while ago, and the second was 3.7.4-23-to-3.7.4-23.1 just recently.  Which
version of LPRng do you currently have installed, and had you applied any
updates prior to the time it worked fine?
Comment 2 Bill Barnes 2002-07-17 08:09:21 EDT
Currently installed version:
[root@piscon /root]# rpm -qa |grep LPR
LPRng-3.7.4-23.1

I'm 90% sure that 3.7.4-23 did not do that error message, or I would have 
posted a bugzilla report.

Some more of the error.
Jul 16 20:50:31 piscon (Server)[17612]: floor31: Open_gdbm: cannot lock 'db.floo
r31' - Interrupted system call
Jul 16 20:56:09 piscon (Server)[18412]: floor31: Open_gdbm: cannot lock 'db.floo
r31' - Interrupted system call
Jul 16 21:06:36 piscon (Server)[18401]: floor32: Open_gdbm: cannot lock 'db.floo
r32' - Interrupted system call
Jul 16 21:09:43 piscon (Server)[18401]: floor32: Open_gdbm: cannot lock 'db.floo
r32' - Interrupted system call

It also looks like if it gets this error too often, it shuts down the print 
queue.

Comment 3 Tim Waugh 2004-12-08 09:01:43 EST
Closing, since we use CUPS now not LPRng.

Note You need to log in before you can comment on or make changes to this bug.