Bug 66683 - System (smp-kernel) hangs during shutdown/reboot
System (smp-kernel) hangs during shutdown/reboot
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-13 11:31 EDT by achim.baecker
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-27 18:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description achim.baecker 2002-06-13 11:31:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Windows NT 5.0; U)

Description of problem:
Trying to reboot after shutdown (shutdown -r now) oder halt after shutdown (shutdown -h now), the systems hangs with the folling messages:

[<c0108c6b>]system_call [kernel]] 0x33

Code f0 fe 08 0f 88 ad 1d 00 00 80 bb 05 01 00 00 00 75 19 86 54
/etc/rc6.d/S01reboot: line 1: 1985 Segmentation fault            reboot -i -d -p
INIT: no more processes left in this runlevel

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. shutdown -r now or shutdown -h now
2.
3.
	

Actual Results:  System hangs 

Expected Results:  halt and/or reboot

Additional info:

Hardware
2x Intel Pentium III (Coppermine) 933 Mhz
Asus CUV4x-D
RAM:  2032 MB
ICP Vortex: GDT G513RS


The Problem is only reproduceable with the smp kernel (2.4.18-4). The normal kernel works fine.
The Value before the phrase "segmentation fault" changes: 1985, 15203...
Comment 1 don.tiller 2002-06-26 15:49:58 EDT
I have experienced the same problem with a system consisting of:

2x Intel Pentium III 933 MHz,
Supermicro 370DL3 mother board
ICP Vortex GDT6518RS
1024 MB RAM
Netgear GA620 (using Acenic driver)

I have tried the 2.4.18-3smp,2.4.18-3bigmem,2.4.18-4smp,2.4.18-5smp kernels all
exhibit the same failing. The 2.4.18-3 and 2.4.18-4 kernels seem fine.
Comment 2 don.tiller 2002-06-26 18:38:45 EDT
I was mistaken, the 2.4.18-5smp kernel seems to have the problem fixed. This
opinion is based upon one successful "shutdown -r now" command.
Comment 3 Need Real Name 2002-07-18 07:34:00 EDT
I'm having similar problems.  Here are my kernel messages for the last shutdown
(it may be a lot, but I don't want to miss anything).  I experienced a hang on
shutdown (blank srcreen, drive lights on).  Turned of the power and the system
recovery was done on reboot.  Could someone explain the 'kernel BUG' message?

Jul 18 14:52:46 killdeer shutdown: shutting down for system halt
Jul 18 14:52:48 killdeer init: Switching to runlevel: 0
Jul 18 14:52:49 killdeer gnome-name-server[1508]: input condition is: 0x11, exiting
Jul 18 14:52:49 killdeer kernel: ------------[ cut here ]------------
Jul 18 14:52:49 killdeer kernel: kernel BUG at page_alloc.c:131!
Jul 18 14:52:49 killdeer kernel: invalid operand: 0000
Jul 18 14:52:49 killdeer kernel: ppp_deflate zlib_deflate ppp_async ppp_generic
slhc emu10k1 sound ac97_codec s
Jul 18 14:52:49 killdeer kernel: CPU:    0
Jul 18 14:52:49 killdeer kernel: EIP:    0010:[<c013948a>]    Tainted: P 
Jul 18 14:52:49 killdeer kernel: EFLAGS: 00013286
Jul 18 14:52:49 killdeer kernel: 
Jul 18 14:52:49 killdeer kernel: EIP is at __free_pages_ok [kernel] 0x11a
(2.4.18-5smp)
Jul 18 14:52:49 killdeer kernel: eax: 00000020   ebx: c11acb88   ecx: c02f1e40 
 edx: 0000364f
Jul 18 14:52:49 killdeer kernel: esi: 00000000   edi: c1000030   ebp: 00000000 
 esp: c89f7e90
Jul 18 14:52:49 killdeer kernel: ds: 0018   es: 0018   ss: 0018
Jul 18 14:52:49 killdeer kernel: Process X (pid: 1362, stackpage=c89f7000)
Jul 18 14:52:49 killdeer kernel: Stack: c024606e 00000083 c039e480 c11acb88
00000000 00000001 c11acb88 00008000 
Jul 18 14:52:49 killdeer kernel:        c11acb88 ffffffff 00008000 40029000
c89f20c0 c012b545 c11acb88 00008000 
Jul 18 14:52:49 killdeer kernel:        00000008 00007000 00000000 40031000
c89fb400 40029000 c03796a0 00000000 
Jul 18 14:52:49 killdeer kernel: Call Trace: [<c012b545>] do_zap_page_range
[kernel] 0x205 
Jul 18 14:52:49 killdeer kernel: [<c01174cd>] do_page_fault [kernel] 0x12d 
Jul 18 14:52:49 killdeer kernel: [<c012bba0>] zap_page_range [kernel] 0x50 
Jul 18 14:52:49 killdeer kernel: [<c012e2d1>] do_munmap [kernel] 0x201 
Jul 18 14:52:49 killdeer kernel: [<c012e3a5>] sys_munmap [kernel] 0x35 
Jul 18 14:52:49 killdeer kernel: [<c0108c6b>] system_call [kernel] 0x33 
Jul 18 14:52:49 killdeer kernel: 
Jul 18 14:52:49 killdeer kernel: 
Jul 18 14:52:49 killdeer kernel: Code: 0f 0b 5f 5d c6 43 24 05 8b 43 18 89 f1 89
dd 83 e0 eb 89 43 
Jul 18 14:52:54 killdeer rhnsd[1321]: Exiting
Jul 18 14:52:55 killdeer rhnsd: rhnsd shutdown succeeded
Jul 18 14:52:55 killdeer atd: atd shutdown succeeded
Jul 18 14:52:55 killdeer Font Server[1265]: terminating 
Jul 18 14:52:55 killdeer xfs: xfs shutdown succeeded
Jul 18 14:52:56 killdeer mysqld: Stopping MySQL:  succeeded
Jul 18 14:52:57 killdeer gpm: gpm shutdown succeeded
Jul 18 14:53:01 killdeer httpd: httpd shutdown succeeded
Jul 18 14:53:01 killdeer sshd: sshd -TERM succeeded
Jul 18 14:53:03 killdeer sendmail: sendmail shutdown succeeded
Jul 18 14:53:03 killdeer xinetd[1020]: Exiting...
Jul 18 14:53:04 killdeer xinetd: xinetd shutdown succeeded
Jul 18 14:53:04 killdeer crond: crond shutdown succeeded
Jul 18 14:53:05 killdeer lpd: lpd shutdown succeeded
Jul 18 14:53:05 killdeer dd: 1+0 records in
Jul 18 14:53:05 killdeer dd: 1+0 records out
Jul 18 14:53:05 killdeer random: Saving random seed:  succeeded
Jul 18 14:53:05 killdeer rpc.statd[837]: Caught signal 15, un-registering and
exiting.
Jul 18 14:53:05 killdeer nfslock: rpc.statd shutdown succeeded
Jul 18 14:53:06 killdeer portmap: portmap shutdown succeeded
Jul 18 14:53:06 killdeer kernel: Kernel logging (proc) stopped.
Jul 18 14:53:06 killdeer kernel: Kernel log daemon terminating.
Jul 18 14:53:07 killdeer syslog: klogd shutdown succeeded
Jul 18 14:53:07 killdeer exiting on signal 15
Jul 18 18:57:51 killdeer syslogd 1.4.1: restart.
Jul 18 18:57:51 killdeer syslog: syslogd startup succeeded
Jul 18 18:57:51 killdeer kernel: klogd 1.4.1, log source = /proc/kmsg started.
Jul 18 18:57:51 killdeer kernel: Linux version 2.4.18-5smp
(bhcompile@daffy.perf.redhat.com) (gcc version 2.96 20000731 (Red Hat Linux 7.3
2.96-110)) #1 SMP Mon Jun 10 15:19:40 EDT 2002
Comment 4 Arjan van de Ven 2002-07-18 08:03:08 EDT
you're not using nvidia are you ?
Comment 5 Need Real Name 2002-07-18 20:05:23 EDT
I am using nvidia.  Installed from source rpm from the nvidia site.  I tried the
driver distributed with RedHat, but exceleration does not work properly.  Have
other people had problems with this driver?
Comment 6 Need Real Name 2002-07-20 18:48:09 EDT
I had this same problem. Asus CUV4x-D with 2x1GHz Coppermine PIII. Clean 
install of RH 7.3.

I ran "up2date --force kernel-smp" from the command line, which upgraded to the 
newest SMP kernel (2.4.18-5), and the problem was resolved! Thanks to #redhat 
on irc.openprojects.net and the other post to this thread (stating that the 
kernel upgrade fixed it) for solving my problem. I am greatly indebted to you!

By the way, Apollo Pro VIA chipsets mobos are terrible with Linux. :-/
Comment 7 Need Real Name 2002-07-29 12:22:25 EDT
when your system now work with 2.4.28-5smp you can close the bug.
Comment 8 Need Real Name 2002-07-29 12:22:27 EDT
when your system now work with 2.4.28-5smp you can close the bug.

Note You need to log in before you can comment on or make changes to this bug.