This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 666916 - eds - crash on comp_subject
eds - crash on comp_subject
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
: Patch
Depends On: 664329 666843 883014
Blocks: 666326
  Show dependency treegraph
 
Reported: 2011-01-03 12:52 EST by ritz
Modified: 2013-06-27 03:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: evolution-data-server-2.32.3-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 03:40:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch based on upstream code (2.07 KB, patch)
2011-01-03 12:52 EST, ritz
mcrha: review-
Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 597567 None None None Never

  None (edit)
Description ritz 2011-01-03 12:52:17 EST
Created attachment 471527 [details]
patch based on upstream code

Description of problem:
crash on comp_subject


Additional info:
proposed patch attached, this would need to be reviewed/tested. 

prereq - Install patched version of libical wrt 
https://bugzilla.redhat.com/show_bug.cgi?id=666843
Comment 1 RHEL Product and Program Management 2011-01-07 10:48:21 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Milan Crha 2011-01-17 05:26:23 EST
Comment on attachment 471527 [details]
patch based on upstream code

I donot agree with the change in e-cal-backend.c. Please move this to the similar place as the upstream bug did it. If not usre, then use e_data_cal_factory_init functions. It's enough to call this function only once, not always when a new ECalBackend is created. Otherwise feel free to commit it, the fix will start to work when a new libical is built and the evolution-data-server is built against it.
Comment 5 Suzanne Yeghiayan 2011-03-28 17:15:23 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains 
unresolved, it has been rejected as it is not proposed as an 
exception or blocker.

Red Hat invites you to ask your support representative to 
propose this request, if appropriate and relevant, in the 
next release of Red Hat Enterprise Linux.
Comment 6 Milan Crha 2013-05-09 08:42:42 EDT
Upstream fix is part of 2.32.3, thus I mark this as a dependency to the rebase bug.
Comment 9 Milan Crha 2013-06-27 03:40:15 EDT
Closing due to comment #6, once the libical will be updated, and the evolution-data-server rebuilt against it, then the included fix will start working.

Note You need to log in before you can comment on or make changes to this bug.